Bug 21405 - conflict between gnome-core(panel) and apm.
conflict between gnome-core(panel) and apm.
Status: CLOSED DUPLICATE of bug 21185
Product: Red Hat Linux
Classification: Retired
Component: gnome-core (Show other bugs)
7.0
All Linux
medium Severity medium
: ---
: ---
Assigned To: David Mason
Dale Lovelace
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2000-11-27 21:26 EST by gbeer
Modified: 2007-04-18 12:30 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2000-11-27 21:26:38 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description gbeer 2000-11-27 21:26:35 EST
This bug report identifies a weakness in gnome-core that allows APM
problems to cause the gnome panel to crash.

PRE-EXISTING ISSUES:
Its a known problem that the current APM code conflicts with the BIOS of
some laptops. 
I report here that on these systems, reading /proc/apm can cause
seg-faults(rh7.0) or system crashes(rh6.2).  I also report that the
"battery_applet" of gnome will seg-fault(rh7.0) on these systems.

OBSERVED PROBLEM WITH GNOME-CORE:
Specifically, under RH7.0. When new user accounts are created, and the user
chooses gnome as his default session manager, the gnome panel seg-faults,
restarts and seg-faults. This action continues until the user manages to
kill it. ("killall -HUP panel" repeated until the respawning process is
caught at the right moment.)

WHY: 
New users must rely on the "last stop" hard coded defaults of
gnome-core-x.x.x/panel/session.c to define their initial panel. On systems
with /proc/apm, session.c forces the inclusion of the battery applet into
the panel. APM problems, identified earlier, cause the battery applet to
fault. That faults the panel, causing the observed problems.  

SOLVING THE PROBLEM. (soapbox alert)
I really hate the fix a problem in the wrong place. Clearly APM is the root
of this problem and needs to be fixed. 

But! where pre-existing problems are known, ignoring them looks bad.
Problems with APM are gnome's problem when ever they are allowed to
intrude.

I hope that the maintainers of session.c will disable the "last stop"
function responsible for including the battery applet in gnome panels. When
the APM/bios conflict is resolved (not likely any time soon) it can be
re-enabled.

Glenn Beer

PS. on a user by user basis. Disabling APM in the kernel allows the panel
to start normally. If the user then saves his current desktop session, He
won't be troubled by this again. This works even if apm is later
re-enabled.
Comment 1 Bill Nottingham 2000-11-28 01:41:45 EST
This is the result of some *seriously* buggy laptop BIOSes. The
manufacturer is working on a BIOS update (in fact, I believe one
may already be available.)


*** This bug has been marked as a duplicate of 21185 ***

Note You need to log in before you can comment on or make changes to this bug.