Bug 214076 - Alsa sound in FC6 not working for ATI SB450 HDA audio card on Toshiba L30 nor on a HP Pavilion Slimline s7620n PC
Alsa sound in FC6 not working for ATI SB450 HDA audio card on Toshiba L30 nor...
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: alsa-lib (Show other bugs)
6
All Linux
medium Severity medium
: ---
: ---
Assigned To: Martin Stransky
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-11-05 08:22 EST by Jason Veitch
Modified: 2007-11-30 17:11 EST (History)
1 user (show)

See Also:
Fixed In Version: kernel-2.6.19-1.2895.fc6
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-03-22 06:10:00 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
The scsconfig log file as requested by fc6 hardware detection (133.40 KB, text/plain)
2006-11-05 08:22 EST, Jason Veitch
no flags Details

  None (edit)
Description Jason Veitch 2006-11-05 08:22:13 EST
Description of problem:

I have a  Toshiba L30 which has a ATI SB450 HDA Audio card according to the 
hardware detection (although doco suggests that it is a Realtek HD card).  
Fedora Core 6 detects the card but does not produce sound.  The alsa mixer 
level is 100%.

The only option I can think of is to try and install 1.0.13 if I can work out 
how to do that - I managed to update the lib but not the core driver.

Version-Release number of selected component (if applicable):
Alsa apparently is 1.0.12 in FC6.  

How reproducible:
Always fails.

Steps to Reproduce:
1.  Requires the hardware I have and is the default detected card that will 
not work.

Actual results:


Expected results:


Additional info:
Attached is the log file from the fedora hardware detection.
Comment 1 Jason Veitch 2006-11-05 08:22:13 EST
Created attachment 140390 [details]
The scsconfig log file as requested by fc6 hardware detection
Comment 2 Martin Stransky 2006-12-14 06:26:38 EST
Could you please check the latest drivers / packages? (ALSA 1.0.14rc1)
How-to is here:

http://people.redhat.com/stransky/alsa/

Comment 3 Fernando Nasser 2007-01-25 09:41:00 EST
The same happens to me on a HP Pavilion Slimline s7620n PC.  It detects this
same ATI sound chipset:

Vendor: ATI
Model: Technologies Inc. SB450 HDA Audio
Module: snd-hda-intel

I will try and find out with HP what is the real sound chipset in the motherboard.

My system has the original FC6 from the DVD installed (I cannot upgrade 
as it makes X11 freeze the machine).  I may try upgrading the kernel only so I
can get the alsa 1.0.14 as suggested (requires the newer kernel-xen to be
installed, for the alsa-kmdl that is required by alsa-drivers 1.0.14).

Some more details:

I've noticed that I don't have a PCM Device when I bring up 
system-config-soundcard.  In my previous system with FC5 there was one.

I did not see any errors on boot with dmsg.

Some file or directory seems to be missing:

# aplay /usr/share/sounds/phone.wav
aplay: main:550: audio open error: No such file or directory

# aplay -D hw:0 /usr/share/sounds/phone.wav
aplay: main:550: audio open error: No such file or directory
Comment 4 Fernando Nasser 2007-01-25 09:52:28 EST
That is what the URL for this machine says:

Onboard audio   	

    *
      Built-in Azalia 8 channel audio
    *
      Realtek ALC883 8-channel High Definition Audio CODEC

Ref.:
http://h10025.www1.hp.com/ewfrf/wc/document?docname=c00784400&lc=en&cc=us&dlc=en&product=3245534&lang=en

It seems it is failing to detect this Realtek card and it is thinking it is an
ATI card (BTW, the rest of the machine's chipsets seem to be from ATI).
Comment 5 Fernando Nasser 2007-01-25 10:12:59 EST
OK, I solved my problem.  I now have a PCM device (ALC883 Analog).

Funny enough, the sound card is still detected as the ATI SB450 HDA

Sound works though, so I don't care what sound chipset it is, ATI or Realtek
(not sure if I can trust the HP docs or if Realtek just OEM something from ATI
anyway).

Both aply commands now work, the missing file has appeared with one of these
packages I've upgraded/installed:
# aplay -D hw:0 /usr/share/sounds/phone.wav
Playing WAVE '/usr/share/sounds/phone.wav' : Signed 16 bit Little Endian, Rate
44100 Hz, Stereo
# aplay /usr/share/sounds/phone.wav
Playing WAVE '/usr/share/sounds/phone.wav' : Signed 16 bit Little Endian, Rate
44100 Hz, Stereo

sound clear and loud.





I installed:

kernel-xen-2.6.19-1.2895.fc6  (the latest for FC6)

alsa-driver-1.0.14-57_rc2.fc6.at
alsa-kmdl-2.6.19-1.2895.fc6xen-1.0.14-57_rc2.fc6.at

The last one, both from the alsa site.

IMPORTANT:  My system did NOT have the alsa-kmdl before, nor the FC6 repos have
it.  I had to install that as it was a dependency for the alsa-driver RPM from
the alsa website listed above.

I hope FC6 is updated, ot that at least these latest alsa drivers are included
in FC7.
Comment 6 Martin Stransky 2007-03-22 06:10:00 EDT
okay, looks fixed in the latest ALSA drivers.

Note You need to log in before you can comment on or make changes to this bug.