Bug 214095 - webcollage -- should this be enabled, or shouldn't it?
webcollage -- should this be enabled, or shouldn't it?
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: xscreensaver (Show other bugs)
6
All Linux
medium Severity medium
: ---
: ---
Assigned To: Mamoru TASAKA
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-11-05 13:05 EST by James Wilkinson
Modified: 2007-11-30 17:11 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-11-21 05:25:08 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description James Wilkinson 2006-11-05 13:05:57 EST
Hi.

https://bugzilla.redhat.com/bugzilla/show_bug.cgi?id=176544 reports that
webcollage was turned OFF for Fedora Core, due to its propensity for displaying
pornography and other undesirable images.

Ray Strode commented that "Webcollage might be an interesting opt-in type thing
for extras though."

I'm still concerned that if an admin should install xscreensaver-extras, and a
user (who might or might not be the same person as the admin) should choose 
"random" screensavers, they will get webcollage without it ever having been
obvious that they are opting in. Could we make it so that users have to
explicitly enable webcollage?

In the meantime, webcollage might not work anyway on most installs -- it has a
runtime dependency on netpbm-progs that isn't reflected in the RPM dependencies.
Comment 1 Mamoru TASAKA 2006-11-05 14:05:17 EST
Well, (for KDE and gnome-screensaver, I don't know)
* on xscreensaver-5.01-3.fc6, webcollage is already disabled by default.
* webcollage in 5.01 now supports  the option '-directory <dir>' 
  which does not use internel connection.

For netpbm-progs dependency, yes, webcollage and vidwhacker has
the dependency for netpdm-progs, however, 'most' hacks work without
this and splitting webcollage and vidwhacker from -extras packages
by this dependency seems of little sense.
Comment 2 Mamoru TASAKA 2006-11-06 12:02:56 EST
Well, I cannot reproduce your situation.

For xscreensaver, you can manually disable each hack even you choose
"Random Screen Saver" mode.
Comment 3 Mamoru TASAKA 2006-11-17 22:37:35 EST
ping?
Comment 4 Mamoru TASAKA 2006-11-21 05:25:08 EST
Closing as NOTABUG, although I made some change on webcollage
in xscreensaver-5.01-4.

Note You need to log in before you can comment on or make changes to this bug.