Bug 214097 - gnome-mount broken again - CDs this time
gnome-mount broken again - CDs this time
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: gnome-mount (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: David Zeuthen
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-11-05 13:36 EST by Michal Jaegermann
Modified: 2013-03-05 22:47 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-03-05 15:01:01 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Michal Jaegermann 2006-11-05 13:36:22 EST
Description of problem:

The current version of gnome-mount works with floppies, and also
with plugged in USB devices, like a USB floppy or a memory stick,
but when trying to use it with a regular iso9660 CD then this ends
up with 

          Unable to mount media.
   There is probably no media in the drive.

alert and even with '-v' added only "gnome-mount 0.5" is printed.

The same happens if one tries any other operation CD, like eject.
There are no problems with mounting that CD using 'mount -r ...'
and a command line 'eject' works with it correctly and with no issues
at all.

Running 'gnome-mount --display-settings -d /dev/cdrom' brings the following:

gnome-mount 0.5
Resolved device file /dev/cdrom -> /dev/hdc
libhal-storage.c 1401 : INFO: called LIBHAL_FREE_DBUS_ERROR but dbusError was
not set.
libhal-storage.c 1344 : INFO: called LIBHAL_FREE_DBUS_ERROR but dbusError was
not set.
libhal-storage.c 1345 : INFO: called LIBHAL_FREE_DBUS_ERROR but dbusError was
not set.
Displaying settings for drive (affects all volumes, unless overridden)
hal udi:      /org/freedesktop/Hal/devices/storage_model_LITE_ON_LTR_52327S
There are no settings; you can use --write-settings

The above suggests a possible double-free in libhal-storage.c but other
than that I cannot find in logs anything which would look even remotely
relevant.

Version-Release number of selected component (if applicable):
gnome-mount-0.5-3.fc7

How reproducible:
always
Comment 3 David Zeuthen 2006-11-06 11:43:10 EST
What version of D-Bus are you running? Also, does the hald die after trying to
mount something? I think this is related to this bug

 http://lists.freedesktop.org/archives/hal/2006-November/006477.html

Comment 4 Michal Jaegermann 2006-11-06 13:03:11 EST
I have at this moment dbus-0.95-1.fc7 and hal-0.5.8.1-4.fc6.

> ... does the hald die after trying to mount something?
I do not think so.  Not only after a failed attempts to mount
CD I can mount other devices through gnome-mount (floppy, USB
storage) but also 'pgrep -f -l hald' after such mount shows:

2713 hald
2714 hald-runner
2720 hald-addon-acpi: listening on acpid socket /var/run/acpid.socket
2724 hald-addon-keyboard: listening on /dev/input/event0

> I think this is related to this bug
> http://lists.freedesktop.org/archives/hal/2006-November/006477.html

Maybe; but I did not notice hald segfaulting.  No cores (I have
that turned on on my test system) and nothing in logs.  On this
hardware gnome-power-manager is not doing very much even if it
is actually installed.
Comment 5 Michal Jaegermann 2006-11-09 14:50:32 EST
Something changed.  I think that I retested after yesterday update
to dbus-0.95-2.fc7, and I have seen the same as before, but I was pretty
busy and now I cannot be absolute sure.  Other changes from today which
look like have a chance to be relevant are dbus-python-0.70-7.fc7 and
gnome-vfs2-2.16.2-2.fc7.

Here is the current deal.  If I am logging into a non-root account with
a CD already in a drive then it gets automatically mounted.  OTOH if
I am putting a CD while already logged then it is NOT mounted even if
in preferences "Mount removable media when inserted" is chosen.  USB
storage auto-mounts as before.  OTOH I can now mount and/or eject that
CD using icon menus in a "Computer" window or 'gnome-mount' directly.
Comment 6 Michal Jaegermann 2006-11-09 15:11:14 EST
Comment #5 notwithstanding gnome-mount is still broken.  When presented
with hfsplus format CD then 'gnome-mount', directly or via icon menus,
flashes on a screen something (probably alert but way too quickly to
even recognize what that may be) and after a while fails to mount anything
at all.  The following shows up in /var/log/messages:

      kernel: cdrom: hdc: mrw address space DMA selected
      kernel: Unable to identify CD-ROM format.

The same disk mounts without any issues at all when tried with
'mount -r /dev/cdrom <mount_point>', 'mount' reports

   /dev/hdc on <mount_point> type hfsplus (ro)

and a corresponding icon appears on desktop.  Curiously enough,
even if 'mount -r ...' is used, I still get in /var/log/messages:
"kernel: hfs: write access to a jounaled filesystem is not
supported, use the force option at your own risk, mounting read-only."
This exactly was asked but maybe a journal?
Comment 7 Michal Jaegermann 2006-11-15 12:52:36 EST
I tried to retest after recent updates to hal and dbus.  Now mounting
CDs is "equal opportunity broken".

If you will try to mount any CD using an icon menu then some kind of
alert (???) flashes on a screen for a miniscule fraction of a second.
Trying that from a command line I am getting these:

$ gnome-mount -v /dev/cdrom
gnome-mount 0.5
GTK Accessibility Module initialized

and once again something flashes on my screen, gnome-mount returns and
nothing is mounted.

Doing the same with a floppy has produces this:

$ gnome-mount -v -d /dev/fd0
gnome-mount 0.5
GTK Accessibility Module initialized

(gnome-mount:3581): Bonobo-CRITICAL **: bonobo_object_unref: assertion
`BONOBO_IS_OBJECT (object)' failed

and a floppy is mounted even in a presence of this "Bonobo-CRITICAL".

Nothing in /var/log/messages apart of mount and unmount notificiation
from floppy unless you will put thee a hfsplus disk.  Then the
following shows up in /var/log/messages:

  ... kernel: hfs: unable to find HFS+ superblock

This would possibly explain previous failures with a hfsplus CD when
something was still sort-of working.  This is _not_ hfs and /bin/mount
has no problems handling it while hfs would also be not an issue.

gnome-mount-0.5-3.fc7
gnome-vfs2-2.16.2-2.fc7
hal-0.5.8.1-6.fc7
dbus-1.0.0-2.fc7
libbonobo-2.16.0-1.fc6
libbonoboui-2.16.0-1.fc6

Comment 8 Michal Jaegermann 2007-03-05 14:51:10 EST
After an update to hal-0.5.9-0.git20070304.fc7 gnome-mount started
to work for me, at last, again.

"Bonobo-CRITICAL **: bonobo_object_unref: assertion `BONOBO_IS_OBJECT (object)'
failed"
mesage is still there.

Now it remains to wait for a long promissed method to adjust a mount
point naming policy without recompiling the whole thing.
Comment 9 David Zeuthen 2007-03-05 15:01:01 EST
You can still adjust mount point names for individual volumes using e.g.
gnome-mount-nautilus-properties. Anyway, closing this bug as you can now mount
CD's again (it was a hal bug all along).
Comment 10 Michal Jaegermann 2007-03-06 17:46:28 EST
> You can still adjust mount point names for individual volumes ...

Don't make me laugh even if this is a sad laughter. That
"individual volumes" is a key phrase here and if you will type 
there something which gnome-mount does not like then you have
problems to change it back.  I would rather not to have to explain
how to do that to end-users for which mounting suddenly broke.

I need to change _policy_ which is now hardwired in gnome-mount.
Then I can use gnome-mount-nautilus-properties to change some
volumes to have mount points derived from labels (if I would ever
got such desire - which is not likely).

Note You need to log in before you can comment on or make changes to this bug.