This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours
Bug 214114 - nfs very verbose when exporting the same mount twice
nfs very verbose when exporting the same mount twice
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: nfs-utils (Show other bugs)
6
All Linux
medium Severity medium
: ---
: ---
Assigned To: Steve Dickson
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-11-05 15:35 EST by Dave Jones
Modified: 2015-01-04 17:29 EST (History)
4 users (show)

See Also:
Fixed In Version: fs-utils-1.0.10-12.fc6
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-06-29 09:43:00 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
Purposed Patch (466 bytes, patch)
2007-03-12 16:19 EDT, Steve Dickson
no flags Details | Diff

  None (edit)
Description Dave Jones 2006-11-05 15:35:30 EST
consider an exports like..

/home/davej/foo   workstation.mydomain.com(rw)
/home/davej/foo   *.mydomain.com(ro)

to make it r/w for one system in mydomain.com, and ro for everyone else.
syslog gets lots of messages of the form..

/home/davej/foo exported to both *.mydomain.com and workstation.mydomain.com in
*.mydomain.com,workstation.mydomain.com

The mounts do behave as I'd expect them to, it's just very noisy.
Comment 1 Habig, Alec 2007-01-23 11:01:53 EST
Ahh good, it's not just me :)  Although no activity on this bug in a couple
months.  I'd settle for verbosity switch - this is making logreading a lot
uglier than it should be.

Any suggestions?
Comment 2 Steve Dickson 2007-03-12 14:42:34 EDT
I'm not seeing these messages with nfs-utils-1.0.10-5.fc6 or
nfs-utils-1.0.12-3.fc7 (the latest rawhide version)

my exports look something like:
/var    10.12.32.32(rw,fsid=1)
/var    *(ro,fsid=1)

and all I'm getting in the systlog when I mount
from any and all clients is:
mountd[4477]: authenticated mount request from <client>:612 for /var (/var)

What am I missing?
Comment 3 Habig, Alec 2007-03-12 15:04:28 EDT
I also have nfs-utils-1.0.10-5.fc6.  My export for /home looks like this, to
enable mountings in general to the whole private subnet
192.168.1.0/255.255.255.0, and add no_root_squash access to one special machine,
neutrino:

  /home   entropy(rw,no_root_squash,sync) neutrino(rw,no_root_squash,sync)
mwah39701(rw,sync) mwah39703(rw,sync) mwah39704(rw,sync) mwah39705(rw,sync)
umd-physics (rw,sync) 192.168.1.0/255.255.255.0(rw,sync)

I'm getting this in /var/log/messages :

  mountd[2644]: /home exported to both 192.168.1.0/255.255.255.0 and neutrino in
192.168.1.0/255.255.255.0,neutrino

But I'm not getting the authenticated mount request message - maybe an NFS v3 vs
v4 issue?  Been meaning to port everything over to v4 but haven't yet gotten
around to it.

Now, my networking is a bit involved, which could be a difference.  Both the
exporting machine ("lepton") and the mounting machine ("neutrino") can talk to
each other on a public network over one NIC, and also on a in-the-lab-only NIC.
 "neutrino" resolves to the internal NIC, 192.168.1.6 via /etc/hosts (and
dnsmasq after that with my own internal DNS).  Name resolution checks out:

  lepton(~)> ping neutrino
  PING neutrino (192.168.1.6) 56(84) bytes of data.
  64 bytes from neutrino (192.168.1.6): icmp_seq=1 ttl=64 time=0.410 ms

Could it be the /etc/exports syntax difference between your global "*" and my
netmasked IP?
Comment 4 Steve Dickson 2007-03-12 16:19:22 EDT
Created attachment 149858 [details]
Purposed Patch

I need to run this by upstream to see if they can
live with turning this warning into a debug statement
but this patch will shut mountd up... I'll trying
to get into a rpm asaic....
Comment 5 Habig, Alec 2007-05-30 15:49:55 EDT
Not sure when exactly the fix got pushed, but checking on my old bugs today,
this one appears to have been fixed.  Using nfs-utils-1.0.10-12.fc6

Thanks!

Note You need to log in before you can comment on or make changes to this bug.