Bug 21412 - anaconda exception during install
Summary: anaconda exception during install
Status: CLOSED DUPLICATE of bug 18032
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: anaconda   
(Show other bugs)
Version: 7.0
Hardware: i686
OS: Linux
high
medium
Target Milestone: ---
Assignee: Michael Fulbright
QA Contact: Brock Organ
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2000-11-28 07:56 UTC by Need Real Name
Modified: 2007-03-27 03:37 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2000-11-28 07:57:54 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
anaconda dump file (979 bytes, text/plain)
2000-11-28 07:57 UTC, Need Real Name
no flags Details

Description Need Real Name 2000-11-28 07:56:56 UTC
Traceback (innermost last):
   File "/var/tmp/anaconda-7.0.1//usr/lib/anaconda/iw/progress_gui.py",
line 20, in run
   rc = self.todo.doInstall ()
     File "/var/tmp/anaconda-7.0.1//usr/lib/anaconda/todo.py",
line 1480, in doInstall
   if self.method.systemMounted (self.fstab, self.instPath, self.hdList.selected()):
     File "/var/tmp/anaconda-7.0.1//usr/lib/anaconda/image.py",
line 46, in systemMounted
   self.loopbackFile = mntPoint + fstab.filesystemSpace(mntPoint)[0][0] + \
     File "/var/tmp/anaconda-7.0.1//usr/lib/anaconda/fstab.py",
line 258, in filesystemSpace
   space.append((mntpoint, isys.fsSpaceAvailable(topMount + '/' + mntpoint)))
     File "/usr/lib/anaconda/isys.py",
line 16, in fsSpaceAvailable
   return _isys.devSpaceFree(fsystem)
SystemError: (2, 'No such file or directory')

Local variables in innermost frame:
  fsystem: /mnt/sysimage//win1

ToDo object:
  (itodo
   ToDo
   p1
   (dp2
   S'method'
   p3
   (iimage
   CdromInstallMethod
   p4
   (dp5
   S'progressWindow'
   p6

<failed>

-------------------------------

The exception appears similar to bug 17889

Hardware:
ram : 128M
HDD : Quantum Fireball 6.4Gb 5400rpm
Motherboard : SuperO P6SBA with Pentium III - 700MHz

Exception occurs just after formatting all partitions.  I was setting up networking for DCHP if that has any bearing.

Comment 1 Need Real Name 2000-11-28 07:57:52 UTC
Created attachment 5768 [details]
anaconda dump file

Comment 2 Daniel Roesen 2000-11-28 16:14:13 UTC
Errata update available.

*** This bug has been marked as a duplicate of 18032 ***


Note You need to log in before you can comment on or make changes to this bug.