Bug 214130 - /usr/bin/w or /usr/bin/who does not display user logged into desktop environment
/usr/bin/w or /usr/bin/who does not display user logged into desktop environment
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: rxvt (Show other bugs)
6
All Linux
medium Severity low
: ---
: ---
Assigned To: Andreas Bierfert
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-11-05 20:58 EST by William Temple
Modified: 2007-11-30 17:11 EST (History)
3 users (show)

See Also:
Fixed In Version: 2.7.10-13.fc7
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-11-26 13:51:43 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description William Temple 2006-11-05 20:58:54 EST
Description of problem:
user that is logged onto the desktop environment is not listed when issuing
/usr/bin/who or /usr/bin/w

Version-Release number of selected component (if applicable):
updated as of 11-05-2006


How reproducible:
always

Steps to Reproduce:
1. log into gnome
2. open terminal
3. execute /usr/bin/who or execute /usr/bin/w
  
Actual results:
user logged on through the graphical environment is not listed in the output

[user@host cwd]# w
 20:52:19 up 8 days,  9:58,  1 user,  load average: 0.67, 0.81, 0.43
USER     TTY      FROM              LOGIN@   IDLE   JCPU   PCPU WHAT
user     pts/0    192.168.1.250    20:28    0.00s  0.13s  0.01s w



Expected results:
I would expect to see the user that is logged into the desktop environment
listed as a logged on user as I am used to seeing on previous releases of FC and
RHEL.

Here is what the output looks like on FC5:
[user@host cwd]$ w
 20:49:33 up  5:51,  3 users,  load average: 0.22, 0.15, 0.05
USER     TTY      FROM              LOGIN@   IDLE   JCPU   PCPU WHAT
user :0       -                14:59   ?xdm?   2:28   0.15s gnome-session
user pts/0    :0.0             20:28    4:20   0.22s  1.43s gnome-terminal
user pts/1    :0.0             20:41    0.00s  0.04s  0.00s w



Additional info:
Comment 1 Tim Waugh 2006-11-06 04:31:47 EST
Sounds like gnome-session forgot to add the utmp entry.
Comment 2 william hanlon 2007-01-16 20:31:52 EST
same behavior is exhibited if I use xterm or rxvt. If I ssh to the box though
those entries are written to lastlog and wtmp.

Ownership/permissions:
ls -alu /var/log/lastlog
-rw-r--r-- 1 root root 2934016 Jan 16 12:04 /var/log/lastlog
ls -alu /var/log/wtmp
-rw-rw-r-- 1 root utmp 97536 Jan 16 12:13 /var/log/wtmp

rpm -q --whatprovides xterm
xterm-223-1.fc6
rpm -q --whatprovides libutempter
libutempter-1.1.4-3.fc6
rpm -q --whatprovides rxvt
rxvt-2.7.10-11.fc6
Comment 3 william hanlon 2007-02-12 22:28:36 EST
Just did yum update tonight and got updated versions of gnome-terminal and
xterm. Both now write entries to wtmp and lastlog. rxvt has not been updated and
still does not work properly.

rpm -q --whatprovides xterm gnome-terminal
xterm-223-2.fc6
gnome-terminal-2.16.0-2.fc6
Comment 4 Matthias Clasen 2007-09-24 21:46:35 EDT
Rassign to rxvt for the remaining issue.
Comment 5 Fedora Update System 2007-11-09 18:57:41 EST
rxvt-2.7.10-13.fc7 has been pushed to the Fedora 7 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update rxvt'
Comment 6 Fedora Update System 2007-11-09 18:58:59 EST
rxvt-2.7.10-14.fc8 has been pushed to the Fedora 8 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update rxvt'
Comment 7 Fedora Update System 2007-11-26 13:51:42 EST
rxvt-2.7.10-13.fc7 has been pushed to the Fedora 7 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 8 Fedora Update System 2007-11-26 13:57:51 EST
rxvt-2.7.10-14.fc8 has been pushed to the Fedora 8 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 9 william hanlon 2007-11-28 21:09:51 EST
rxvt does not make wtmp entries for me on Fedora 8. If I run rxvt as a
non-privileged user, no entry in /var/log/wtmp is made, but if I run rxvt as
root, then entries are made. So it seems there's a problem with permissions.

on my machine:
ls -al /var/log/[wu]tmp /var/log/lastlog 
-rw-r--r-- 1 root root 146292 2007-11-28 19:02 /var/log/lastlog
-rw-rw-r-- 1 root utmp 479616 2007-11-28 19:02 /var/log/wtmp
ls -al /var/run/[wu]tmp                  
-rw-rw-r-- 1 root utmp 6144 2007-11-28 19:02 /var/run/utmp

Comment 10 Andreas Bierfert 2007-11-29 03:49:23 EST
As stated in the update:

"This still depends on utempter(#246063) to be fixed for #214130 to really work
but it is all that can be done for rxvt."

But nobody seems to care about #246063 ...

Note You need to log in before you can comment on or make changes to this bug.