This service will be undergoing maintenance at 00:00 UTC, 2016-09-28. It is expected to last about 1 hours
Bug 214131 - Can't open FLAC files
Can't open FLAC files
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: audacious (Show other bugs)
6
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Ralf Ertzinger
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-11-05 21:27 EST by djh
Modified: 2007-11-30 17:11 EST (History)
2 users (show)

See Also:
Fixed In Version: 1.1.2-4
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-11-09 01:42:01 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description djh 2006-11-05 21:27:51 EST
audacious-1.1.2-2.fc6 will not open any of my FLAC files.  Attempting to add any
to my playlist results in the following dialog box:


Unable to play files.

The following files could not be played. Please check that:
1. they are accessible.
2. you have enabled the media plugins required.


- the FLAC plugin is enabled in Audacious Preferences page.  The Preferences and
Information buttons on that same page work, so the plugin seems to dlopen() okay
- the rpm verifies
- setenforce 0 doesn't help
- mplayer (from livna) plays the FLACs okay
Comment 1 Ralf Ertzinger 2006-11-06 09:24:56 EST
Playing flac works fine for me. Where are the files located (local filesystem,
http..)? Do the filenames contain spaces or percent signs (%)?
Comment 2 djh 2006-11-06 21:59:22 EST
The files are on local filesystems (ext3 and FAT32), with and without
spaces/percent-signs in the filenames.  I've tried copying FLACs with strange
names to /tmp/foo.flac and it still doesn't work.

I've only put FC6 on two of my systems (both fresh FC6 i386 installs), and
neither one will open FLACs via audacious.
Comment 3 djh 2006-11-06 22:24:56 EST
Here's an interesting comment on the front page of the Audacious website.

---
GNOME-VFS support being removed  (5 November 2006)
Versions of Audacious after 1.2.1 will no longer have GNOME-VFS support. It is
being removed due to a ton and a half of bugs (it never really worked right).
---

Looking at the strace output, i agree with their assessment.  I select one flac
file, click open, and get 38 of these:
open("file:///tmp/foo.flac", O_RDONLY)  = -1 ENOENT (No such file or directory)

It does eventually strip the file:// URI prefix, but it still doesn't work.
Comment 4 Ralf Ertzinger 2006-11-07 07:19:27 EST
Reading through the code I have to agree with that. Half of the plugins do not
work right with gnome-vfs (which is a shame, really).

I'll push a build without gnome-vfs shortly. 1.2.x should be forthcoming to FC6,
too.
Comment 5 Dominik 'Rathann' Mierzejewski 2006-11-07 19:24:19 EST
I've already packaged 1.2.1 and plugins for myself because of bug #214351. Would
you like me to send you the specfiles?
Comment 6 Ralf Ertzinger 2006-11-08 15:26:25 EST
You do not have to switch to 1.2.1 to get rid of gnome-vfs, that can be disabled
at build time. FC-6 has a version without it by now.

Thanks for the spec file offer, but I am mostly done here. Due to the size of
the change the resulting files will have to pass review once again, so do not
expect "official" 1.2.x packages in the next days.
Comment 7 djh 2006-11-09 01:42:01 EST
Cheers, --disable-gnome-vfs has fixed it.

Note You need to log in before you can comment on or make changes to this bug.