Bug 214144 - Firefox doesn't start on ppc64
Firefox doesn't start on ppc64
Product: Fedora
Classification: Fedora
Component: firefox (Show other bugs)
ppc64 Linux
medium Severity high
: ---
: ---
Assigned To: Christopher Aillon
Depends On:
  Show dependency treegraph
Reported: 2006-11-06 02:56 EST by Zoltan Kota
Modified: 2007-11-30 17:11 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2007-04-18 01:06:22 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)

External Trackers
Tracker ID Priority Status Summary Last Updated
Mozilla Foundation 361415 None None None Never

  None (edit)
Description Zoltan Kota 2006-11-06 02:56:37 EST
Description of problem:

After a normal graphical install of FC6 on an iMac G5 (ppc64) firefox does not
start in Gnome. Typing 'firefox' in terminal nothing happens, I get the prompt back:

[zkota@csimac ~]$ firefox
[zkota@csimac ~]$ 

Yum remove, yum install doesn't help.
[zkota@csimac ~]$ yum list firefox
Loading "fastestmirror" plugin
Loading "installonlyn" plugin
Setting up repositories
Loading mirror speeds from cached hostfile
Reading repository metadata in from local files
Installed Packages
firefox.ppc                              installed       
firefox.ppc64                            installed       
[zkota@csimac ~]$ 

Epiphany and galeon work fine.
Any idea?
Comment 1 Josh P. 2006-11-29 00:33:44 EST
I see this issue as well.

For submitter, workaround is to run the 32bit version directly.

Comment 2 Nicholas Miell 2007-01-13 23:43:26 EST
Just to clarify what's going on -- the PPC64 XPCOM stubs aren't merged, so
Firefox can't possibly run on PPC64. The build still succeeds, yet produces a
completely non-functional binary.

See https://bugzilla.mozilla.org/show_bug.cgi?id=361415

Comment 3 Matthias Clasen 2007-04-17 18:50:15 EDT
Chris, is this still an issue ? Didn't dwmw fix the xpcom stubs at some point ?
Comment 4 Christopher Aillon 2007-04-18 01:06:22 EDT

Note You need to log in before you can comment on or make changes to this bug.