Bug 214157 - SW raid5 module is missing from 2.6.18-1.2200.fc5 initrd image.
SW raid5 module is missing from 2.6.18-1.2200.fc5 initrd image.
Status: CLOSED DUPLICATE of bug 211030
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
5
x86_64 Linux
medium Severity medium
: ---
: ---
Assigned To: Kernel Maintainer List
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-11-06 05:11 EST by Gilboa Davara
Modified: 2007-11-30 17:11 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-11-12 00:36:58 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Gilboa Davara 2006-11-06 05:11:41 EST
Description of problem:
Updated my FC5 setup to 2.6.18-2200 but it failed to detect my LVM over RAID5 setup.
Seems the mkinitrd failed to create a boot-able initrd image.
Last working kernel - 2.6.17-2174.

$ gunzip -c /boot/initrd-2.6.18-1.2200.fc5.img | cpio -t | sort > 2200.txt
10260 blocks
$ gunzip -c /boot/initrd-2.6.17-1.2174_FC5.img | cpio -t | sort > 2174.txt
10806 blocks
$ diff -u 2174.txt 2200.txt
--- 2174.txt  2006-11-06 12:06:58.000000000 +0200
+++ 2200.txt  2006-11-06 12:06:28.000000000 +0200
@@ -46,12 +46,10 @@
 lib/ext3.ko
 lib/jbd.ko
 lib/libata.ko
-lib/raid5.ko
 lib/sata_nv.ko
 lib/scsi_mod.ko
 lib/scsi_transport_spi.ko
 lib/sd_mod.ko
-lib/xor.ko
 proc
 sbin
 sys

Both xor.ko and raid5.ko are missing.

Version-Release number of selected component (if applicable):
2.6.18-1.2200.fc5

How reproducible:
Always.

- Gilboa
Comment 1 Dave Jones 2006-11-12 00:36:58 EST

*** This bug has been marked as a duplicate of 211030 ***

Note You need to log in before you can comment on or make changes to this bug.