Bug 214158 - latest binutils trigger strange: "!samegp reloc against symbol without .prologue"
latest binutils trigger strange: "!samegp reloc against symbol without .prolo...
Status: CLOSED UPSTREAM
Product: Fedora
Classification: Fedora
Component: binutils (Show other bugs)
rawhide
alpha Linux
medium Severity high
: ---
: ---
Assigned To: Jakub Jelinek
It gives "!samegp reloc against symbo...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-11-06 05:15 EST by Balint Cristian
Modified: 2007-11-30 17:11 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-11-06 07:04:54 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
A small testcase. (161 bytes, text/plain)
2006-11-06 05:15 EST, Balint Cristian
no flags Details


External Trackers
Tracker ID Priority Status Summary Last Updated
Sourceware 3449 None None None Never

  None (edit)
Description Balint Cristian 2006-11-06 05:15:34 EST
During the port of -devel for alpha [http://alphacore.info] we stuck with binutils. 
Unfortunatley i nor Sergey not expert of alpha relocations so we try to post this 
showstopper bug:

Output:
# gcc -v conftest.c
Using built-in specs.
Target: alpha-redhat-linux
Configured 
with: ../configure --prefix=/usr --mandir=/usr/share/man --infodir=/usr/share/info 
--enable-shared --enable-threads=posix --enable-checking=release --with-system-zlib 
--enable-__cxa_atexit --disable-libunwind-exceptions --enable-libgcj-multifile 
--enable-languages=c,c++,objc,obj-c++,java,fortran --enable-java-awt=gtk 
--disable-dssi --with-java-home=/usr/lib/jvm/java-1.4.2-gcj-1.4.2.0/jre 
--with-long-double-128 --host=alpha-redhat-linux
Thread model: posix
gcc version 4.1.0 20060228 (Red Hat 4.1.0-1)
 /usr/libexec/gcc/alpha-redhat-linux/4.1.0/cc1 -quiet -v 
conftest.c -quiet -dumpbase conftest.c -auxbase 
conftest -version -o /tmp/ccrEun0F.s
ignoring nonexistent 
directory "/usr/lib/gcc/alpha-redhat-linux/4.1.0/../../../../alpha-redhat-linux/include"
#include "..." search starts here:
#include <...> search starts here:
 /usr/local/include
 /usr/lib/gcc/alpha-redhat-linux/4.1.0/include
 /usr/include
End of search list.
GNU C version 4.1.0 20060228 (Red Hat 4.1.0-1) (alpha-redhat-linux)
        compiled by GNU C version 4.1.0 20060228 (Red Hat 4.1.0-1).
GGC heuristics: --param ggc-min-expand=46 --param ggc-min-heapsize=31269
Compiler executable checksum: 6e0ce0c6bed7a40ac43c080bacb332d6
 as -no-mdebug -o /tmp/ccevgZqf.o /tmp/ccrEun0F.s
 /usr/libexec/gcc/alpha-redhat-linux/4.1.0/collect2 --eh-frame-hdr -m 
elf64alpha -O1 -dynamic-linker /lib/ld-linux.so.2 /usr/lib/gcc/alpha-redhat-linux/4.1.0/../../../crt1.o /usr/lib/gcc/alpha-redhat-linux/4.1.0/../../../crti.o /usr/lib/gcc/alpha-redhat-linux/4.1.0/crtbegin.o -L/usr/lib/gcc/alpha-redhat-linux/4.1.0 -L/usr/lib/gcc/alpha-redhat-linux/4.1.0 -L/usr/lib/gcc/alpha-redhat-linux/4.1.0/../../.. /tmp/ccevgZqf.o -lgcc --as-needed -lgcc_s --no-as-needed -lc -lgcc --as-needed -lgcc_s --no-as-needed /usr/lib/gcc/alpha-redhat-linux/4.1.0/crtend.o /usr/lib/gcc/alpha-redhat-linux/4.1.0/../../../crtn.o
/usr/bin/ld: /tmp/ccevgZqf.o: !samegp reloc against symbol without .prologue: 
longval
/usr/bin/ld: final link failed: Nonrepresentable section on output
collect2: ld returned 1 exit status

# rpm -q gcc binutils glibc
gcc-4.1.0-1
binutils-2.17.50.0.6-2
glibc-2.4-4axp

Manifestation:

1) Using older binutils 2.16 works, so guess its binutils related too.
2) As I switch to $subj version the bug appear, [while gcc remains the same]
3) Further testing by using vanilla gcc + vanilla binutils it is reproductibile too.
Comment 1 Balint Cristian 2006-11-06 05:15:34 EST
Created attachment 140445 [details]
A small testcase.
Comment 2 Jakub Jelinek 2006-11-06 07:04:54 EST
If the problem is with vanilla gcc and vanilla binutils, then please file
it against upstream binutils instead (http://sources.redhat.com/bugzilla/).
Comment 3 Balint Cristian 2006-11-06 07:14:48 EST
Hello Jakub !

Well, the problem is with redhat's pakage, i just mentioned that vannila too triggered the 
problem.Its already filled on sourceware: http://sourceware.org/bugzilla/show_bug.cgi?id=3449 
too.So if want you can close here, i duplicate the post here too because sometimes guys from 
sourceware when hear that i struggle with redhat package they redirect me here :-)

BTW, I mark the observation on sourceware that vanilla too has the issue.


Note You need to log in before you can comment on or make changes to this bug.