Bug 214173 - umount fails on NFS server when NFS client has blocking lock request
umount fails on NFS server when NFS client has blocking lock request
Status: CLOSED DUPLICATE of bug 214172
Product: Red Hat Enterprise Linux 4
Classification: Red Hat
Component: kernel (Show other bugs)
4.4
All Linux
medium Severity high
: ---
: ---
Assigned To: Peter Staubach
Ben Levenson
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-11-06 07:19 EST by Asha Ramamurthy Yarangatta
Modified: 2007-11-16 20:14 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-12-08 11:18:04 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Asha Ramamurthy Yarangatta 2006-11-06 07:19:40 EST
Description of problem:
Unmounting the filesystem fails if the NFS client has sent the blocking lock 
request to a file in the NFS exported filesystem. Stopping the nfs server does 
not also help. The server node needs to be rebooted inorder to unmount the 
filesystem 

Version-Release number of selected component (if applicable):
nfs-utils-1.0.6-70.EL4

How reproducible:
Always

Steps to Reproduce:
On Server
1. Mount the device(/dev/vgnfs/lvxfs) on the directory /NFS1.
2. Start nfs and nfslock.
3. Export the directory /NFS1.

Need two client machines.
1. In one client, send lock request to a file in the NFS exported FS (which is 
   a mounted filesystem) and hold lock.
2. In another client, send blocking lock request to the same file as above.
   Then, this request will be waiting for the lock to be released.

On server
3. Unexport the NFS filesystem, Send SIGKILL to lockd thread and stop the NFS
   server (by shutting down nfs and nfslock)
4. Unmount the device
  
Actual results:
On server, unmounting the filesystem will fail
umount: /NFS1: device is busy
umount: /NFS1: device is busy
To unmount the filesystem, the node needs to be rebooted.

Expected results:
After unexporting filessytems and releasing all the locks , umounting should 
happen without any problem. But this is not happening even after killing of nfsd

Additional info:
NFS server is on Red Hat Enterprise Linux AS release 4 (Nahant Update 4) and NFS 
clients are on RH4 U3 or RH4 U4.

The code used for acquiring the blocking lock is attached. The program accepts 
the file to be locked as an argument.
Comment 1 Asha Ramamurthy Yarangatta 2006-11-06 07:34:55 EST
(In reply to comment #0)
Its a duplicate of bug with id "214172". When I clicked "Back" on my browser, 
it got registered once again in the database. Please ignore this and remove 
from the database if possible.

> Description of problem:
> Unmounting the filesystem fails if the NFS client has sent the blocking lock 
> request to a file in the NFS exported filesystem. Stopping the nfs server 
does 
> not also help. The server node needs to be rebooted inorder to unmount the 
> filesystem 
> Version-Release number of selected component (if applicable):
> nfs-utils-1.0.6-70.EL4
> How reproducible:
> Always
> Steps to Reproduce:
> On Server
> 1. Mount the device(/dev/vgnfs/lvxfs) on the directory /NFS1.
> 2. Start nfs and nfslock.
> 3. Export the directory /NFS1.
> Need two client machines.
> 1. In one client, send lock request to a file in the NFS exported FS (which 
is 
>    a mounted filesystem) and hold lock.
> 2. In another client, send blocking lock request to the same file as above.
>    Then, this request will be waiting for the lock to be released.
> On server
> 3. Unexport the NFS filesystem, Send SIGKILL to lockd thread and stop the NFS
>    server (by shutting down nfs and nfslock)
> 4. Unmount the device
>   
> Actual results:
> On server, unmounting the filesystem will fail
> umount: /NFS1: device is busy
> umount: /NFS1: device is busy
> To unmount the filesystem, the node needs to be rebooted.
> Expected results:
> After unexporting filessytems and releasing all the locks , umounting should 
> happen without any problem. But this is not happening even after killing of 
nfsd
> Additional info:
> NFS server is on Red Hat Enterprise Linux AS release 4 (Nahant Update 4) and 
NFS 
> clients are on RH4 U3 or RH4 U4.
> The code used for acquiring the blocking lock is attached. The program 
accepts 
> the file to be locked as an argument.

Comment 2 Peter Staubach 2006-12-08 11:18:04 EST

*** This bug has been marked as a duplicate of 214172 ***

Note You need to log in before you can comment on or make changes to this bug.