Bug 214189 - Can't print with Samsung ML-2010
Can't print with Samsung ML-2010
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: cups (Show other bugs)
6
x86_64 Linux
medium Severity medium
: ---
: ---
Assigned To: Tim Waugh
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-11-06 09:20 EST by Victor Lorenz
Modified: 2011-09-06 13:33 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-11-09 11:18:34 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
cups error log (1.30 MB, text/plain)
2006-11-06 13:48 EST, Victor Lorenz
no flags Details

  None (edit)
Description Victor Lorenz 2006-11-06 09:20:44 EST
Description of problem:

Can't print from Samsung ML-2010
Version-Release number of selected component (if applicable):
Using ASUS M2NPV-VM motherboard Bios upgraded to ver. 504
cups-1.2.4-9
How reproducible:

Every time printing requested
Steps to Reproduce:
1.Downloaded latest Linux Unified drivers from samsung (ver. 2.00.90)
2. As root installed drivers
3. Install goes to the Printer Prgram and finds ML-2010
4. Test page does not print
4.
  
Actual results:
 Attempt at printing with Open office gives msg. /usr/lib64/cups/filter/raster
tosamsung failed
Printing from Firefox shows Enter Bug (Expert)


Expected results:
Printing

Additional info:

Checked printer in Windows and it works OK. Worked with Fedora 5 on different
box. New box with clean FC 6 install
Comment 1 Victor Lorenz 2006-11-06 10:15:05 EST
When machine rebooted Printer configurations showed two occurrance of the
printer; the one I set up with device/dev/mfp4 URL usb:samsung etc and a second
with same parameters as in Bug 214178 i.e added by HAL and Sharp.
I attempted to delete HAL version but got msg
"CUPS server error
There was an error during the CUPS operation: 'server-error-service-unavailable'."
Now both printers have disappeared from Printer configuration.
Can't attempted add printers as server connection fails with msg:
"There was an error during cups operation "http ConnectionEncrypt failed'"
Comment 2 Tim Waugh 2006-11-06 10:55:47 EST
Please edit /etc/cups/cupsd.conf and change the 'LogLevel' line to read:

  LogLevel debug2

Then stop cups:

  /sbin/service cups stop

Clear out the error log:

  >/var/log/cups/error_log

and restart it:

  /sbin/service cups start

Then try your print job again, and attach the /var/log/cups/error_log file to
this bug report.  Thanks.
Comment 3 Victor Lorenz 2006-11-06 13:48:56 EST
Created attachment 140495 [details]
cups error log
Comment 4 Victor Lorenz 2006-11-06 14:26:47 EST
Oops Note to go with above attachment: Followed proposed steps. Stopping cups
failed as cups apparently already stopped. Both ML-2010 (HAL settings) amd
ml2010 (my settings) appear in Print Configuration. Tried printing from OO
Writer wiith both settings. ML-2010 did get a response from printer (motor
going) but no print out. Nothing from ml2010. Mesg in OO writer Print dialog box
"/usr/lib64/cups/filter/rastertosamsungspl failed" beside ml2010 nothing beside
ML-2010.
Upgraded to update test version of System-print-configuration as per 214178
Comment 5 Tim Waugh 2006-11-07 11:13:27 EST
E [06/Nov/2006:13:25:59 -0500] PID 5900
(/usr/lib64/cups/filter/rastertosamsungspl) stopped with status 22!
D [06/Nov/2006:13:25:59 -0500] [Job 33]
/usr/lib64/cups/filter/rastertosamsungspl: Permission denied

What does 'ls -lZ /usr/lib64/cups/filter' say?
Comment 6 Victor Lorenz 2006-11-07 16:59:03 EST
-rwxr-xr-x  jrtriads jrtriads root:object_r:lib_t              pscms
-rwxr-xr-x  jrtriads jrtriads root:object_r:lib_t              rastertosamsungpc
l
-rwxr-xr-x  jrtriads jrtriads root:object_r:lib_t              rastertosamsungsp
l
-rwxr-xr-x  jrtriads jrtriads root:object_r:lib_t              rastertosamsungsp
                                          lc

and for /usr/lib/cups/filter (in case it's relevent)
lrwxrwxrwx  root root system_u:object_r:lib_t          foomatic-rip -> ../../../
                                          bin/foomatic-rip
-rwxr-xr-x  root root system_u:object_r:bin_t          gziptoany
-rwxr-xr-x  root root system_u:object_r:bin_t          hpgltops
-rwxr-xr-x  root root system_u:object_r:bin_t          imagetops
-rwxr-xr-x  root root system_u:object_r:bin_t          imagetoraster
-rwxr-xr-x  root root system_u:object_r:bin_t          pdftops
-rwxr-xr-x  root root system_u:object_r:bin_t          pstopdf
-rwxr-xr-x  root root system_u:object_r:bin_t          pstops
-rwxr-xr-x  root root system_u:object_r:bin_t          pstopxl
-rwxr-xr-x  root root system_u:object_r:bin_t          pstoraster
lrwxrwxrwx  root root system_u:object_r:lib_t          rastertodymo -> rastertol
                                          abel
-rwxr-xr-x  root root system_u:object_r:bin_t          rastertoepson
-rwxr-xr-x  root root system_u:object_r:bin_t          rastertohp
-rwxr-xr-x  root root system_u:object_r:bin_t          rastertolabel
lrwxrwxrwx  root root system_u:object_r:lib_t          texttopaps -> /usr/bin/pa
                                          ps
-rwxr-xr-x  root root system_u:object_r:bin_t          texttops
Comment 7 Tim Waugh 2006-11-09 09:32:42 EST
Try this:

chcon system_u:object_r:bin_t /usr/lib64/cups/filter/rastertosamsung*
chown root:root /usr/lib64/cups/filter/rastertosamsung*

Does that help?
Comment 8 Victor Lorenz 2006-11-09 10:17:11 EST
Yes it does! The latest updates of cups and system etc got rid of the spurious
printer from HAL but it still wouldn't printer. Testing gave msg. that it
couldn't find anything on the USB port. But your suggested code works.  Thx
Comment 9 Tim Waugh 2006-11-09 11:18:34 EST
So Samsung needs to fix their installer.  Thanks for helping to find the problem.
Comment 10 Michael Appleyard 2006-11-10 21:32:28 EST
I too am having the exact same problem with a Samsung SCX-4200 Multi-function
Printer. The scanner works fine, but it just refuses to print, the closest I
came was a few seconds of whiring then nothing. After a while of tinkering, I
started getting CUPS server errors, I even tried re-installing but that did not
help.
My system is Fedora Core 6 (x86_64) and the printer was connected via USB. The
printer has worked fine with other Linux Distros I have tried including Knoppix
5.0.1, Ubuntu 6.10 and Suse 10.1 just by installing the driver off the Samsung
website.
Comment 11 Tim Waugh 2006-11-11 05:35:30 EST
Michael: Fedora Core ships with SELinux in enforcing mode.  The Samsung folks
need to fix their installer to run '/sbin/restorecon -v
/usr/lib/cups/filter/rastertosamsung* ||:' after installing the files.
Comment 12 Michael Appleyard 2006-11-11 10:42:06 EST
I see, is this something I can fix myself, (by turning SELinux off, or pasting a
few lines into the installer's shell script)? Or do I have to wait for an
updated driver? I emailed Samsung, but have yet to get a reply.
Comment 13 Tim Waugh 2006-11-13 09:15:05 EST
Run these commands as root:

restorecon /usr/lib64/cups/filter/rastertosamsung*
chown root:root /usr/lib64/cups/filter/rastertosamsung*
Comment 14 Michael Appleyard 2006-11-13 20:43:19 EST
That works an absolute treat, thanks so much!
Comment 15 anthony.s.hughes 2011-09-06 13:33:43 EDT
Is there anyone who knows contact information at Samsung so they are aware of this issue?

Also, would it be possible to elevate this to the Fedora Printing documentation?

Note You need to log in before you can comment on or make changes to this bug.