Bug 214203 - up2date to Application Stack channel fails from vanilla U4
up2date to Application Stack channel fails from vanilla U4
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 4
Classification: Red Hat
Component: up2date (Show other bugs)
4.4
All Linux
medium Severity medium
: ---
: ---
Assigned To: Sayli Karmarkar
Preethi Thomas
: Reopened
: 214522 241864 (view as bug list)
Depends On: 494388
Blocks:
  Show dependency treegraph
 
Reported: 2006-11-06 10:32 EST by Joe Orton
Modified: 2015-03-22 21:08 EDT (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-05-18 16:13:34 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Joe Orton 2006-11-06 10:32:57 EST
Description of problem:
Installing php from the Application Stack channel fails if attempted from a
vanilla RHEL4 U4 @Everything installation.

It succeeds from fully up-to-date U4 system.

Version-Release number of selected component (if applicable):
up2date-4.4.69-25

How reproducible:
always

Steps to Reproduce:
1. RHEL4 U4 @Everything kickstart
2. subscribe to rhel-i386-as-4-appstk-1
3. run "up2date --installall rhel-i386-as-4-appstk-1"
  
Actual results:
...
Unresolvable chain of dependencies:
php-pear-4.3.9-3.18                      requires php = 4.3.9-3.18

Expected results:
installation of new PHP packages

Additional info:
Notes:

a) there is a dep loop between php and php-pear, both require each other
b) in RHEL base, php-pear is a subpackage of the i386 php package
c) in the Stack, php-pear is a noarch standalone package
d) there has been a php erratum since RHEL4 U4, the -3.18 release

I suspect the problem here is that the update transaction from RHEL4 U4 vanilla
to (RHEL4 U4 errata + all Stack channel) is picking up *both* the erratum
php-pear and the Stack php, and not coping.
Comment 1 Deepak Bhole 2006-11-08 11:27:24 EST
*** Bug 214522 has been marked as a duplicate of this bug. ***
Comment 2 Red Hat Bugzilla 2007-04-11 21:38:25 EDT
User bnackash@redhat.com's account has been closed
Comment 3 Joe Orton 2007-05-31 05:02:01 EDT
*** Bug 241864 has been marked as a duplicate of this bug. ***
Comment 4 RHEL Product and Program Management 2007-11-28 23:23:19 EST
This request was evaluated by Red Hat Product Management for inclusion in a Red
Hat Enterprise Linux maintenance release.  Product Management has requested
further review of this request by Red Hat Engineering, for potential
inclusion in a Red Hat Enterprise Linux Update release for currently deployed
products.  This request is not yet committed for inclusion in an Update
release.
Comment 7 Joe Orton 2008-02-29 03:55:42 EST
I don't see any attempt to follow the specific reproduction recipe given above:

1. RHEL4 U4 @Everything kickstart
2. subscribe to rhel-i386-as-4-appstk-1
3. run "up2date --installall rhel-i386-as-4-appstk-1"
Comment 8 Sayli Karmarkar 2008-02-29 12:29:01 EST
Joe,
Even with "up2date --installall rhel-i386-as-4-appstk-1", it does not show the
specified error because of the reason I specified above. The output shows:

[root@rlx-0-22 ~]# up2date --installall rhel-i386-as-4-appstk-1

Fetching Obsoletes list for channel: rhel-i386-as-4...

Fetching Obsoletes list for channel: rhel-i386-as-4-appstk-1...

Fetching rpm headers...
########################################

Name                                    Version        Rel     
----------------------------------------------------------
MySQL-python                            1.2.1_p2       1.el4.1           i386  
antlr                                   2.7.6          3jpp.ep1.2        noarch
asm                                     1.5.3          1jpp.ep1.1        noarch
avalon-framework                        4.1.5          1jpp.ep1.2        noarch

...
...

xpp2                                    2.1.10         4jpp.ep1.1        noarch
xpp3                                    1.1.3.4        1.o.2jpp.ep1.1    noarch


Testing package set / solving RPM inter-dependencies...
There was a package dependency problem. The message was:

Unresolvable chain of dependencies:
berkeleydb-2.0.90-1jpp.ep1.1             requires java >= 0:1.4.2 
hibernate3-annotations-3.2.1-1.patch01.1 requires java >= 0:1.5 
hibernate3-ejb-persistence-3.0-api-3.2.1 requires java >= 0:1.5 
hibernate3-entitymanager-3.2.1-1jpp.ep1. requires java >= 0:1.5 
jboss-profiler  1.0-0.1.CR5.1jpp.ep1.2   requires java
jboss-seam  1.2.1-1.ep1.2                requires java
jbossas  4.2.0-2.CP01.ep1.4              requires java-1.5.0
jbossas  4.2.0-2.CP01.ep1.4              requires java-1.5.0-devel
quartz-1.5.2-1jpp.ep1.2                  requires java >= 0:1.4 
regexp  1.4-3jpp.ep1.2                   requires java
wsdl4j  1.6.2-1jpp.ep1.6                 requires java

It does not enlist php dependency problem. After installing java, it din't show
any dependency problems and installed packages from appstk without error.  

-Sayli
Comment 20 Sayli Karmarkar 2009-03-17 19:20:33 EDT
Moving back to assigned. I have a fix for this. However, need to confirm with prad about whether we want to add the fix in this release. Its a simple change but seems to be regression prone.
Comment 28 Preethi Thomas 2009-04-06 13:05:50 EDT
moving this one to verified. opening another bug for the other issue
https://bugzilla.redhat.com/show_bug.cgi?id=494388
Comment 30 errata-xmlrpc 2009-05-18 16:13:34 EDT
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on therefore solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2009-0972.html

Note You need to log in before you can comment on or make changes to this bug.