Bug 214216 - can't mount a specific video DVD
can't mount a specific video DVD
Status: CLOSED INSUFFICIENT_DATA
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
6
All Linux
medium Severity medium
: ---
: ---
Assigned To: Kernel Maintainer List
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-11-06 12:33 EST by Andre Robatino
Modified: 2007-12-31 17:10 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-12-31 17:10:57 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Andre Robatino 2006-11-06 12:33:14 EST
Description of problem:
  I have a specific video DVD which will not mount, either automatically or
manually.  If I attempt to mount it (I'm assuming the filesystem type is udf
based on other video DVDs which do mount):

[root@localhost ~]# mount -t udf /dev/hdc /mnt/windows/
mount: block device /dev/hdc is write-protected, mounting read-only
mount: wrong fs type, bad option, bad superblock on /dev/hdc,
       missing codepage or other error
       In some cases useful info is found in syslog - try
       dmesg | tail  or so

and /var/log/messages shows

Nov  6 12:18:15 localhost kernel: attempt to access beyond end of device
Nov  6 12:18:15 localhost kernel: hdc: rw=0, want=68, limit=4
Nov  6 12:18:15 localhost kernel: attempt to access beyond end of device
Nov  6 12:18:15 localhost kernel: hdc: rw=0, want=1252, limit=4
Nov  6 12:18:15 localhost kernel: attempt to access beyond end of device
Nov  6 12:18:15 localhost kernel: hdc: rw=0, want=1028, limit=4
Nov  6 12:18:15 localhost kernel: UDF-fs: No partition found (1)

The same DVD worked previously on Fedora (I bought it last year, don't remember
the last time playing it) using the same DVD-R/RW drive.  Other video DVDs I
have continue to work properly, both automounting and playing.

Version-Release number of selected component (if applicable):
kernel-2.6.18-1.2798.fc6

How reproducible:
always

Additional info:
  Clean install of FC6.  Until last week I had another box, also clean FC6
install, on which the same DVD automounted, but when trying to play it with xine
or mplayer it would use essentially 100% of the CPU and still not be able to
play properly.  Other DVDs worked properly on that box as well.
Comment 1 Andre Robatino 2006-11-13 06:00:52 EST
  Problem still exists with kernel-2.6.18-1.2849.fc6.  I also applied the latest
firmware upgrade for the DVD drive (NEC ND-2510A) with no change.  But the same
DVD worked on the same DVD drive last year (June 2005 to be precise) on the
latest version of Fedora at the time, though the DVD drive was in a different PC
then.  I suspect there is something flaky about this DVD since I bought my copy
just after the DVD was released, and my father has a version of the same DVD
with a timestamp about a month after I bought mine, and his mounts and plays
properly on a box running FC6, which I sent to him about 2 weeks ago.  Before I
sent it, I tried my copy of the DVD, and it mounted, but didn't play properly
with xine - it used 100% of the CPU and couldn't keep up.  Normally a DVD would
only use about 70%.

  So to sum up, this particular video DVD will mount on some but not all FC6
boxes.  Even if it mounts, it may have problems with excessive CPU use
attempting to play it.  If it doesn't mount, it will probably give the error
messages shown in my earlier comment.
Comment 2 Andre Robatino 2006-11-13 10:41:40 EST
  My box is dual boot WinXP/FC6.  The same problem exists in WinXP.  I contacted
the vendor who sold me the DVD.  If I can get more info about what's wrong with
the DVD, I'll add it here. 
Comment 3 Jon Stanley 2007-12-31 16:56:59 EST
Hello,

I'm reviewing this bug as part of the kernel bug triage project, an attempt to
isolate current bugs in the Fedora kernel.

http://fedoraproject.org/wiki/KernelBugTriage

I am CC'ing myself to this bug, however this version of Fedora is no longer
maintained.

Please attempt to reproduce this bug with a current version of Fedora (presently
Fedora 8). If the bug no longer exists, please close the bug or I'll do so in a
few days if there is no further information lodged.

Thanks for using Fedora!
Comment 4 Andre Robatino 2007-12-31 17:10:57 EST
  I was able to get a modified version of the DVD from the vendor dated one
month later, which didn't suffer from the problem, so there was something wrong
with the way the original DVD was created.  In addition, the DVD mounts in my
box which has a newer DVD drive, but still not in my older FC6 box using the
original DVD drive, which I am currently unable to update to F7 or F8 due to a
failure by the installer to detect the HD.  So I will close this due to
insufficient data.

Note You need to log in before you can comment on or make changes to this bug.