Bug 214223 - Obsolete version distributed by Redhat does not work with current RedHat distributed Kernel
Obsolete version distributed by Redhat does not work with current RedHat dist...
Status: CLOSED WONTFIX
Product: Red Hat Enterprise Linux 4
Classification: Red Hat
Component: lm_sensors (Show other bugs)
4.4
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Phil Knirsch
David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-11-06 13:00 EST by wrking
Modified: 2015-03-04 20:17 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-08-18 12:41:52 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description wrking 2006-11-06 13:00:18 EST
Description of problem:

The version of lm_sensors which RedHat distributes does not work correctly 
since it is obsolete (years old). Some of the modules which are used by 
lm_sensors are contained in the kernel. Therefore the lm_sensors applications 
do not work with the current RehHat distributed kernel. For example, run decode-
dimms.pl and it will tell you that /proc/sys/dev/sensors does not exist. The 
current kernel uses /sys/bus/i2c/drivers/eeprom/... for storing the files. If 
you update to the current version of lm_sensors, it does work.


Version-Release number of selected component (if applicable):

lm_sensors-2.8.7-2.40.3


How reproducible:


Steps to Reproduce:
1. run /usr/bin/decode-dimms.pl (it fails)
2.
3.
  
Actual results:


Expected results:


Additional info:
Comment 1 Phil Knirsch 2008-08-18 12:41:52 EDT
This request was evaluated by Red Hat Engineering for inclusion in a Red
Hat Enterprise Linux maintenance release.

Red Hat does not currently plan to provide this change in a Red Hat Enterprise
Linux update release for currently deployed products.

With the goal of minimizing risk of change for deployed systems, and in
response to customer and partner requirements, Red Hat takes a conservative
approach when evaluating enhancements for inclusion in maintenance updates
for currently deployed products. The primary objectives of update releases
are to enable new hardware platform support and to resolve critical
defects.

However, Red Hat will further review this request for potential inclusion
in future major releases of Red Hat Enterprise Linux.

Note You need to log in before you can comment on or make changes to this bug.