Bug 21424 - Poisson RNG
Poisson RNG
Status: CLOSED DEFERRED
Product: Red Hat Powertools
Classification: Retired
Component: R-base (Show other bugs)
7.0
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Tim Powers
:
Depends On: 21423
Blocks:
  Show dependency treegraph
 
Reported: 2000-11-28 09:24 EST by Plummer, Martyn
Modified: 2008-05-01 11:37 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2000-12-14 11:18:47 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Plummer, Martyn 2000-11-28 09:24:05 EST
The Poisson random number generator in R fails to generate correct
samples.  The tail of the distribution is truncated.  This appears to be
due to a bug in gcc 2.96 that I have submitted as #21423.
Comment 1 Tim Powers 2000-11-28 11:13:02 EST
Just a quick question about this. If R-base is built without optimizations, you
don't have any problems? Even with the other modules?

Tim
Comment 2 Plummer, Martyn 2000-11-28 11:41:41 EST
R-base builds and passes "make check" without optimizations, but I think it will
be unacceptably slow. Users of scientific sotware normally want to drive their
machines pretty hard and expect high performance.

I'm distributing R (via CRAN: www.r-project.org) RPMS for Red Hat 7.0 built with
gcc 2.95.2, which works well. An alternative for you might be to use kgcc in
place of gcc, but retaining g77 2.96 for the parts written in Fortran.  This
worked for me, but it has been reported that this leads to problems dynamically
loading R packages written in FORTRAN (e.g. akima).
Comment 3 Tim Powers 2000-11-28 12:10:47 EST
Hmm. If it would slow it down the releasing unoptimized packages is not a good
solution. Thanks for pointing that out.

Unfortunately my hands are tied on this until gcc is fixed :/ If I use kgcc and
then g77 on the fortran stuff  as you mentioned, it will break other things
whcih is also unacceptable. My only good option is to keep bugging Jakub until
it's fixed.

Tim
Comment 4 Tim Powers 2000-11-30 13:58:40 EST
I'm deferring this until gcc is fixed. Once gcc is fixed I will rebuild and
release an errata for R-base.

Tim
Comment 5 Tim Powers 2001-01-14 16:09:17 EST
I am closing this since and errata was released for this.

Tim

Note You need to log in before you can comment on or make changes to this bug.