Bug 21427 - ocamldebug is actually ocamlrun
Summary: ocamldebug is actually ocamlrun
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Powertools
Classification: Retired
Component: ocaml   
(Show other bugs)
Version: 7.0
Hardware: i386 Linux
medium
medium
Target Milestone: ---
Assignee: Tim Powers
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2000-11-28 15:20 UTC by Yaron Minsky
Modified: 2008-05-01 15:37 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2000-11-29 23:04:59 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Yaron Minsky 2000-11-28 15:20:46 UTC
Oddly, the ocaml RPM is weirdly compiled, so that ocamldebug looks like a
version of ocamlrun (although it is not the same file as the ocamlrun
executbale included.)  To verify, just try to feed it on eof the
command-line options for ocamldebug, and you'll see it doesn't work.

I'm not sure what the problem is exactly.  I donwloaded pristine sources
and compiled them with only the memmove patch, and that ocamldebug worked
fine. The pristine sources do not compile fully without the memmove patch
I haven't tried the included sources, or the sparc patch.

A quick of correctness.  ocamldebug should give the following re

snapdragon: SOURCES $ ocamldebug
No program name specified
Usage: ocamldebug [options] <program> [arguments]
Options are:
  -I <dir>  Add <dir> to the list of include directories
  -s <filename>  Set the name of the communication socket
  -c <count>  Set max number of checkpoints kept
  -cd <dir>  Change working directory
  -emacs For running the debugger under emacs

If it doesn't (for instance, it says something about missing a bytecode
file) then there's a problem.

Comment 1 Yaron Minsky 2000-11-28 15:23:44 UTC
I just checked --- the ocaml tar file contained on the RPM is in fact the
pristine sources.  So the problem is either the sparc patch or somehow in the
install.  I suspect it's the sparc patch.

Comment 2 Tim Powers 2000-11-28 17:54:30 UTC
It's the same file, only stripped. Unstripped it has all the flags.

Tim

Comment 3 Tim Powers 2000-11-28 18:03:35 UTC
After a quick look at some of the other binaries, none of them can be stripped.
If they are, the exact smae behavior is exibited. I am working on an errata
release for this now.

Tim

Comment 4 Tim Powers 2000-11-29 23:04:56 UTC
An errata has been released for this ( RHBA-2000:119-02 ). Thanks for the report.

Tim


Note You need to log in before you can comment on or make changes to this bug.