This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 214304 - GUI is laggy in new version
GUI is laggy in new version
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: audacious (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Ralf Ertzinger
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-11-06 18:28 EST by Mephisto
Modified: 2007-11-30 17:11 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-11-09 10:15:36 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Mephisto 2006-11-06 18:28:08 EST
Description of problem:
The GUI is very laggy after installing the new package version. It looks like
the GUI is only updated a few times per second. This didnt happen with the older
package.

Version-Release number of selected component (if applicable):
1.1.2-4.fc7

How reproducible:
always

Steps to Reproduce:
1. install the latest audacious package
2.
3.
  
Actual results:
GUI lags.

Expected results:
GUI should behave like the previous package (update frequently enough)

Additional info:
You may want to update to the latest version while you're at it. 1.2.1 has been
out for a while...
Comment 1 Ralf Ertzinger 2006-11-07 07:22:32 EST
Yes, the version pushed to FC7 yesterday has the update frequency reduced
somewhat (the original updates the window a hundred times a second, even when
idle, which seemed a bit excessive to me). I'll push the frequency higher again.

1.2.x is forthcoming, but will require some more work due to the upstream split
into player and plugins.
Comment 2 Mephisto 2006-11-07 10:22:29 EST
i see...
i don't know how easy this is to implement (seems trivial to me, but i may
overlook some things), but maybe using the setting from the visualization would
be a good idea. you can select 50, 25, 12 and 6 there. that way, people can
choose what they prefer. personally i'd stick with 50, cause my machine is fast
enough that i don't notice audacious' cpu usage at all, while others might
prefer a lower setting.
Comment 3 Mephisto 2006-11-08 16:05:24 EST
just installed the new package, and uhm, i'm sorry, but it still feels laggy.
especially the scrolling song title is horrible. feels like it's some opengl app
that's running in a too low framerate :/
i dont know what frequency it runs on now, but i'd prefer it to be higher...
Comment 4 Ralf Ertzinger 2006-11-09 10:15:36 EST
I dropped the patch in question, everything ought to be back to normal.

Note You need to log in before you can comment on or make changes to this bug.