Bug 2143276 - I have a problem that gdm is not working on wayland
Summary: I have a problem that gdm is not working on wayland
Keywords:
Status: NEW
Alias: None
Product: Fedora
Classification: Fedora
Component: gdm
Version: 37
Hardware: x86_64
OS: Linux
unspecified
unspecified
Target Milestone: ---
Assignee: Ray Strode [halfline]
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2022-11-16 14:15 UTC by stevebug
Modified: 2022-11-19 20:58 UTC (History)
8 users (show)

Fixed In Version:
Doc Type: ---
Doc Text:
Clone Of:
Environment:
Last Closed:
Type: Bug


Attachments (Terms of Use)
journalctl -b -1 -r (285.22 KB, text/plain)
2022-11-16 14:15 UTC, stevebug
no flags Details
journalctl -b -r (269.00 KB, text/plain)
2022-11-17 16:43 UTC, David Fox
no flags Details
journalctl -u gdm (164.03 KB, text/plain)
2022-11-17 21:31 UTC, stevebug
no flags Details

Description stevebug 2022-11-16 14:15:15 UTC
Created attachment 1924709 [details]
journalctl -b -1 -r

Created attachment 1924709 [details]
journalctl -b -1 -r

Description of problem:
Hello, I executed the update command "sudo dnf update --refresh",
 and immediately after that without rebooting,
I executed the upgrade command "sudo dnf system-upgrade download --releasever=37" in the boot normal mode, the boot process takes place until "Started gdm.services" reached, and here it freezes.
I cannot use "ctrl-alt-f1 to f7",using a liveusb i uncomment "waylandenable=false" at /etc/gdm/custom.conf.
It worked normally and you logged in X11.
i've intel gpu. 
I used it fpaste And these outputs:https://paste.centos.org/view/7631fd94

Comment 1 David Fox 2022-11-17 16:43:37 UTC
Created attachment 1925056 [details]
journalctl -b -r

Comment 2 David Fox 2022-11-17 16:45:14 UTC
Same error.  Submitted journalctl -b -r of the relevant boot.

ASUS UX305 FA, onboard Intel graphics
Mesa Intel HD Graphics 5300 (BDW GT2)

Comment 3 stevebug 2022-11-17 21:31:35 UTC
Created attachment 1925119 [details]
journalctl -u gdm

Comment 4 Hashem Nasarat 2022-11-18 13:18:37 UTC
This is being discussed here: https://ask.fedoraproject.org/t/fedora-37-wont-boot-after-update-yesterday-10-01-22/27151/12

This seems like a major bug. It's happening on Fedora 37 upgrades and also upgrades on arch linux. It requires booting into a non-graphical TTY and manually installing a package, or modifying a config file, to resolve. Otherwise the computer is unusable.

Comment 5 David Fox 2022-11-18 18:47:06 UTC
I just read on another thread that the problem can be fixed by installing intel-media-driver.
It worked for me. I can now boot into Wayland.

Comment 6 stevebug 2022-11-18 20:18:12 UTC
I installed the package and it didn't solve the problem.

Comment 7 stevebug 2022-11-19 20:58:41 UTC
Thank you very much, I solved the problem by updating to gnome-shell-43.1-3.fc37.x86_64.


Note You need to log in before you can comment on or make changes to this bug.