Bug 214343 - Inability to browse SMB shares in Nautilus and VFS aware software
Inability to browse SMB shares in Nautilus and VFS aware software
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: gnome-vfs2 (Show other bugs)
6
x86_64 Linux
medium Severity medium
: ---
: ---
Assigned To: Alexander Larsson
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-11-06 23:57 EST by Gian Paolo Mureddu
Modified: 2007-11-30 17:11 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-11-20 13:24:20 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Gian Paolo Mureddu 2006-11-06 23:57:29 EST
Description of problem:
Nautilus and a other VFS aware applications (such as Totem, Rhythmbox, Listen,
etc) and those utilizing the gnome file dialogs (open/save) which are present in
quite a few of other applications, and use gnome-vfs to access other filesystems
which are mounted virtually (like SMB in this case), are not able to access and
browse SMB shares. Some examples:

Opening Nautilus (in any mode) and trying to mount an SMB share via vfs (with
the Connect to Server... dialog), the share will be present in the computer:///
location, however, when trying to actually open that share (unless is an
annonymous share) a dialog pups up to enter the username (if it is another
different than the current session), Domain (I've always assumed WorkGroup here)
and the password for the session. What happens is that this dialog keeps popping
up constantly until I press [cancel] or some times, it would appear that the
first time the password is typed, then an error message pops up saying that the
contents of the share couldn't be shown.

Another example is using a KDE application to browse the share (like Konqueror)
and then trying to launch a file using a GNOME VFS-aware application to view it
(like Gedit, Totem, etc), what will happen is that the same user/domain/password
pop up will keep popping up constantly until I press the [cancel] and then an
error dialog will pop up sayin that the file cannot be opened.

Also servers and shares *are* shown, just the shares are not browsable, as when
trying to access those the restrictions in smb.conf will kick in per share, so
until I want to browse a certain share, the user/domain/password should be sent
to the server... Anyway, I want to point out that this is not an issue in Fedora
Core 5 VFS implementation. 


Version-Release number of selected component (if applicable):

gnome-vfs2-smb-2.16.0-4.fc6
gnome-vfs2-devel-2.16.0-4.fc6
gnome-vfs2-2.16.0-4.fc6

How reproducible:

Always

Steps to Reproduce:
1. Open Nautilus and either type smb://server/share or browse the Netowrk:/// to
a server with restricted access SMB shares.
2. Nautilus will display the server and the shares, try to browse them
3. Either an endless loop of dialogs asking for user/domain/password will pop up
or an error message that the contents could not be shown.
  
Actual results:

Inability to browse access restricted SMB shares with Nautilus.

Expected results:

To be able to browse restrcited SMB shares with Nautilus (if the
user/domain/password combination is correct)

Additional info:

Needless to say that in Windows (various versions) and with other filemanagers
(Konqueror) SMB shares work just fine. I'd also like say that the server in
question is running samba-3.0.23c-1.fc5. Also worth noting is that this same
configuration works perfectly with a plethora of other different clients (Xbox,
several Windows machines, other Linux [FC5] boxes, etc; except my FC6 desktop).
Comment 1 Alexander Larsson 2006-11-08 06:37:04 EST
Strange. It works for me. I wonder what the difference is.
Comment 2 Gian Paolo Mureddu 2006-11-08 14:01:25 EST
I wondered if the problem is an "inherited" home directory. However, I have a
"dummy" account which I use to test a lot of stuff, and even when whiping that
account of any trace of gnome configurations (only residual files are bashrc
profiles), I see the exact same behavior, very strange indeed!
Comment 3 Gian Paolo Mureddu 2006-11-08 17:41:08 EST
It's been brought to my attention that this other bug may be related to this
one, or this one is in fact a duplicate of that other bug... Here's the link:

https://bugzilla.redhat.com/bugzilla/show_bug.cgi?id=214183

Here's my original report on Fedoraforum.org:

http://forums.fedoraforum.org/showthread.php?p=672197
Comment 4 Alexander Larsson 2006-11-09 04:35:55 EST
That error was a bug that was fixed in the latest update, but it shouldn't cause
infinite password dialogs, so this bug seems different.
Comment 5 Leo Canale 2006-11-19 18:08:21 EST
see https://bugzilla.redhat.com/bugzilla/show_bug.cgi?id=214183

Rick 
Iā€™m still having problems also, and noticed that it is not solved. I also 
noticed it will bomb if it has to authenticate. I also run ubuntu and it has 
the same problem.
Rick you might want to post here instead because this bug report is closed.

https://bugzilla.redhat.com/bugzilla/show_bug.cgi?id=214343
Comment 6 Rick 2006-11-19 19:17:20 EST
Same here, I am running fc6 with:

gnome-vfs2-smb-2.16.0-4.fc6
gnome-vfs2-devel-2.16.0-4.fc6
gnome-vfs2-2.16.0-4.fc6

Whenever I attempt to connect to a Windows share with nautilus, I recieve the
following in messages...

Nov 19 19:12:32 mercury kernel: gnome-vfs-daemo[3107]: segfault at
0000000000000020 rip 00002aaaaaafef24 rsp 0000000041e01930 error 6

I have uninstalled gnome-vfs2 and reinstalled with same results.  I can mount
the shares with:

mount -t cifs //192.168.20.14/biggie /biggie
-o user=user1,password=xxxx,domain=DOMAIN

or run smbclient to connect to the shares.  So I'm pretty sure Samba is running
correctly.

-Rick
Comment 7 Botond 2006-11-20 08:32:54 EST
(In reply to comment #0)

I think Nautilus always wants to log in as [WORKGROUP]\GUEST to the server
regardless of the actual username given in the "Authentication required" dialog
box. At least this is what I see in my own /var/log/samba/... logs.
Comment 8 Alexander Larsson 2006-11-20 10:12:00 EST
Yeah, it first tries as guest, and if that fails it asks the user for
authentication. To override, specify a username in the uri (i think).

Comment 9 Gian Paolo Mureddu 2006-11-20 12:31:08 EST
Yes, you can use the smb://user@server syntaxis, but that defeats the purpose of
browsing the network... at least I think it does.
Comment 10 Alexander Larsson 2006-11-20 13:24:20 EST
Well, a lot of people complained about the constant barrage of authentication
dialogs when browsing shares that allowed anonymous login, so we made it default
to log in as guest. If you need to log in as a specific user you need to specify
that now.

No option will make everyone happy of course...

Closing this bug then. (Assuming this is the problem you're having)
Comment 11 Adam Huffman 2006-12-18 19:41:18 EST
I have created https://bugzilla.redhat.com/bugzilla/show_bug.cgi?id=220126 as
I'm seeing similar behaviour even when I specify a username and password.

Note You need to log in before you can comment on or make changes to this bug.