Bug 214363 - rpm should depend on db4-utils
rpm should depend on db4-utils
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: rpm (Show other bugs)
6
All Linux
medium Severity low
: ---
: ---
Assigned To: Paul Nasrat
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-11-07 04:27 EST by Patrice Dumas
Modified: 2007-11-30 17:11 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-11-07 04:38:06 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Patrice Dumas 2006-11-07 04:27:13 EST
Description of problem:

db_verify, needed for example by  /usr/lib/rpm/rpmdb_verify may not
be installed. It is in db4-utils. 

It is a serious issue in my opinion because sometimes it seems to
be the only way to bring rpm database back to life.

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:
Comment 1 Paul Nasrat 2006-11-07 04:38:06 EST
rpmdb_verify is db_verify from the internal version of Sleepycat.

rpm -e db4-utils
cd /var/lib/rpm
/usr/lib/rpm/rpmdb_verify Packages

Works for me.
Comment 2 Patrice Dumas 2006-11-07 04:44:58 EST
Indeed, I got it wrong. In fact I was confused by the error
message of /usr/lib/rpm/rpmdb_verify which referred to 
db_verify, so I incorrectly assumed that rpmdb_verify
was a wrapper... Sorry for the noise.

Maybe the error message could be changed, but that may be
too much work for little gain...

Note You need to log in before you can comment on or make changes to this bug.