This service will be undergoing maintenance at 20:00 UTC, 2017-04-03. It is expected to last about 30 minutes
Bug 21438 - ld.so.conf contains redundant /usr/lib
ld.so.conf contains redundant /usr/lib
Status: CLOSED NOTABUG
Product: Red Hat Linux
Classification: Retired
Component: ldconfig (Show other bugs)
7.0
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Jakub Jelinek
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2000-11-28 13:30 EST by rock
Modified: 2008-05-01 11:37 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2000-11-28 18:08:17 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description rock 2000-11-28 13:30:49 EST
/usr/lib is in /etc/ld.so.conf.  This is uneccisary, since ldconfig 
searches it by default.  It makes ldconfig -v complain.  Furthermore, it 
seems to slow down ldconfig somewhat.
Comment 1 Jakub Jelinek 2000-11-29 06:38:30 EST
/usr/lib is inserted into ld.so.conf by some packages in their %post scripts
(because if those packages are relocated somewhere else, they need to register
their library paths with ldconfig). Those scripts could test if the library
path is different than /lib and /usr/lib, but as it is harmless, I don't think
they need to be changed.

Note You need to log in before you can comment on or make changes to this bug.