Bug 214402 - Kernel BUG at lib/list_debug.c:31 invalid opcode: 0000 [1] SMP
Kernel BUG at lib/list_debug.c:31 invalid opcode: 0000 [1] SMP
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
x86_64 Linux
medium Severity medium
: ---
: ---
Assigned To: Kernel Maintainer List
Brian Brock
Depends On:
  Show dependency treegraph
Reported: 2006-11-07 09:09 EST by Jim Hayward
Modified: 2008-08-02 19:40 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2008-01-07 19:31:44 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)
Kernel trace (7.18 KB, text/plain)
2006-11-07 09:09 EST, Jim Hayward
no flags Details
dmesg output (20.93 KB, text/plain)
2006-11-07 09:10 EST, Jim Hayward
no flags Details
Add an INIT_LIST_HEAD() (506 bytes, patch)
2006-11-15 02:01 EST, Dan Carpenter
no flags Details | Diff

  None (edit)
Description Jim Hayward 2006-11-07 09:09:56 EST
Description of problem:
I just happened to notice it in /var/log/messages this morning.

The system was rock solid stable with a single core AMD64 processor. After
updating to an X2 processor it is not as stable. There was occasional drive
errors, lockups with FC5. The system seems much more stable with FC6. Still
getting occasional random lockups in X when using Firefox.

Let me know if I can provide any more helpful details.

Version-Release number of selected component (if applicable):

How reproducible:
Have not tried to reproduce it.

Additional info:
Comment 1 Jim Hayward 2006-11-07 09:09:56 EST
Created attachment 140558 [details]
Kernel trace
Comment 2 Jim Hayward 2006-11-07 09:10:47 EST
Created attachment 140559 [details]
dmesg output
Comment 3 Trevin Beattie 2006-11-15 00:09:12 EST
This appears to be a duplicate of Bug #198350.  I've attached my own log output

I've seen the same error on both a dual-Opteron 270HE and a virtual machine with
just a single CPU allocated.  The host system is able to keep running with the
other CPU's taking over; the single-processor vm locks up hard.
Comment 4 Dan Carpenter 2006-11-15 02:01:37 EST
Created attachment 141233 [details]

Trevin, I don't think this is the same as yours.  Both bugs are list related
but I don't think they have the same root cause.

I looked through the code but it doesn't seem like INIT_LIST_HEAD() is ever
called so the ->prev and ->next pointers would be bogus.  I've attached a patch
to fix that.
Comment 5 Jon Stanley 2007-12-31 17:07:30 EST

I'm reviewing this bug as part of the kernel bug triage project, an attempt to
isolate current bugs in the Fedora kernel.


I am CC'ing myself to this bug, however this version of Fedora is no longer

Please attempt to reproduce this bug with a current version of Fedora (presently
Fedora 8). If the bug no longer exists, please close the bug or I'll do so in a
few days if there is no further information lodged.

Thanks for using Fedora!
Comment 6 Jon Stanley 2008-01-07 19:31:44 EST
Closing per previous comment.  If you can provide the requested information,
please feel free to re-open this bug.

Note You need to log in before you can comment on or make changes to this bug.