Bug 214404 - Laptop does not suspend when unplugged from the wall with lid closed
Laptop does not suspend when unplugged from the wall with lid closed
Status: CLOSED UPSTREAM
Product: Fedora
Classification: Fedora
Component: gnome-power-manager (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: David Zeuthen
: Reopened
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-11-07 09:21 EST by Daniel Walsh
Modified: 2013-03-05 22:47 EST (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-05-14 04:40:58 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
GNOME Desktop 331655 None None None Never

  None (edit)
Description Daniel Walsh 2006-11-07 09:21:59 EST
Description of problem:

I have configured my laptop to suspend when the lid is closed and running on
battery. It is supposed to blank screen when closing on AC.  I noticed that if I
close the laptop at the end of the day, and then unplug it the laptop stays
running.  It should suspend.

gnome-power-manager-2.17.2.1-1.fc7
 uname -r
2.6.18-1.2798.fc6
Comment 1 David Zeuthen 2006-11-07 10:53:58 EST
This is not a bug, it's a design decision.

However /apps/gnome-power-manager/battery_event_when_closed should do what you
want: 

"If the battery lid close event should occur (for example 'Suspend when lid
closed on battery') when the lid is previously shut and the AC power
disconnected at a later time."

Use gconf-editor to toggle this yourself.
Comment 2 Daniel Walsh 2006-11-07 12:21:10 EST
Well then change this to a request for enhancement, since I believe this is the
wrong decision.  It is natural at the end of the day to close the laptop and
then unplug it.  Having it super heat in the bag is a bad idea.  Similarly if I
had the laptop in a docking station I would figure it would suspend when
disconnected with the lid closed.  I see very little reason do leave the laptop
running by default if I say suspend on battery when lid closed.

Comment 3 Jesse Keating 2006-11-07 13:10:18 EST
I do believe other operating systems work this way by default as well.  If you
unplug while closed, it will go into a suspend state.  Or at least thats what
happend the last time I used said other operating systems ( a few years back ).
 Changing the behaviour w/out significantly good reason should be avoided as to
not add confusion to migrating users or dualboot users.
Comment 4 David Zeuthen 2006-11-07 13:13:40 EST
Maybe so, it makes more and more sense to me the more I read it. Richard, was
there any good reason the default doesn't do this?
Comment 5 Christopher Aillon 2006-11-07 13:38:36 EST
I filed this upstream a while ago.  http://bugzilla.gnome.org/show_bug.cgi?id=331655
Comment 6 Richard Hughes 2006-11-07 14:35:12 EST
No real technical reason, only I got a few bugzillas about the weird behaviour.
It was also done at the point in the history where HAL was not correctly
refreshing the lid status (it's been fixed in CVS for a few months) and setting
this option was bad, as the lid was always "closed" and hence kept re-suspending.

If the lid status is always correct, then it's insanity not to use this option.
Unfortunatly, lid status still is incorrect for some (significant, and vocal
few) people - but I think we might be good to enable this for 2-17.

Richard.
Comment 7 Richard Hughes 2007-05-14 04:40:58 EDT
2007-05-14  Richard Hughes  <richard@hughsie.com>

	* data/gnome-power-manager.schemas.in:
	Change the /apps/gnome-power-manager/battery/event_when_closed
	key to default to true. This means that if you shut the lid and then
	remove the AC power then the system will by default suspend.
	This may make systems that have dodgey lid reporting to immediatly
	suspend when removed from AC, but we can blacklist (or fix) them as
	they are reported. Fixes fedora:214404

Committed to 2-19. Let the bugzillas commence. :-)

Note You need to log in before you can comment on or make changes to this bug.