Bug 214408 - 500 error on SDC config SubscriptionsSetup page
Summary: 500 error on SDC config SubscriptionsSetup page
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat Network
Classification: Red Hat
Component: RHN/Web Site (Show other bugs)
(Show other bugs)
Version: rhn500
Hardware: All Linux
medium
medium
Target Milestone: ---
Assignee: Partha Aji
QA Contact: Steve Salevan
URL:
Whiteboard:
Keywords:
Depends On:
Blocks: rhn500h-config-mgmt
TreeView+ depends on / blocked
 
Reported: 2006-11-07 14:52 UTC by Ken Ganong
Modified: 2007-04-18 17:52 UTC (History)
1 user (show)

Fixed In Version: rhn500h
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-03-13 02:57:04 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Ken Ganong 2006-11-07 14:52:44 UTC
I get an internal server error page whenever I attempt to go to the
subscriptions setup page for config management in the SDC.

Here is a portion of the relevant stacktrace

Caused by: com.redhat.rhn.common.db.datasource.ParameterValueNotFoundException:
Could not set null value for parameter: user_id        at
com.redhat.rhn.common.db.datasource.CachedStatement.setupParamMap(CachedStatement.java:335)
        at 
...
com.redhat.rhn.manager.configuration.ConfigurationManager.listGlobalChannelsForSystemSubscriptions(ConfigurationManager.java:130)
        at
com.redhat.rhn.frontend.action.configuration.sdc.SubscriptionsSetupAction.getDataResult(SubscriptionsSetupAction.java:42)

Comment 1 Partha Aji 2006-12-08 00:44:55 UTC
Resolved...
1) Login 
2) Systems - > Select a system
3) Add provisioning to a system
4) Select configuration
5) Select Manage Configuration Channels
6) Select Subscribe to channel.. 

Make sure no internal error arises...


Comment 2 Steve Salevan 2007-01-11 19:41:15 UTC
QA Contact -> ssalevan

No internal error arises when the test plan is run.  Thus, I'm moving this bug
to VERIFIED.

Comment 3 Steve Salevan 2007-03-06 20:35:35 UTC
It's good on Stage, moving to RELEASE_PENDING.

Comment 4 Brandon Perkins 2007-03-13 02:57:04 UTC
Closed in the rhn500h Release.


Note You need to log in before you can comment on or make changes to this bug.