Bug 214412 - x264 selinux issues
Summary: x264 selinux issues
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Fedora
Classification: Fedora
Component: selinux-policy-targeted   
(Show other bugs)
Version: 6
Hardware: All Linux
medium
medium
Target Milestone: ---
Assignee: Daniel Walsh
QA Contact: Ben Levenson
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2006-11-07 15:03 UTC by Matěj Cepl
Modified: 2018-04-11 08:45 UTC (History)
1 user (show)

Fixed In Version: Current
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-08-22 14:11:40 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Matěj Cepl 2006-11-07 15:03:13 UTC
Description of problem:
The bug was originally filed as
http://bugzilla.livna.org/show_bug.cgi?id=1243:

When running ffmpeg it crashes with the following error:

ffmpeg: error while loading shared libraries: /usr/lib/libx264.so.54: cannot
restore segment prot after reloc: Permission denied

This crash occurs as both a normal user and root.

----

The problem was later identified as a problem with text relocations. As per 
http://post-office.corp.redhat.com/mailman/private/memo-list/2006-November/msg00262.html
I am filing this bug here as well.

Version-Release number of selected component (if applicable):
selinux-policy-targeted-2.4.2-3.fc6

How reproducible:
100% with SELinux in enforcing mode

Steps to Reproduce:
1.start ffplay (or anyother application using ffmpeg libraries, e.g., it is
reproducible with mplayer as well) and it crashes with error message:

ffplay: error while loading shared libraries: /usr/lib/libx264.so.54: cannot
restore segment prot after reloc: Permission denied

(the same selinux error is generated by rhythmbox and mplayer or probably any
other application using ffmpeg libraries or gstreamer-ffmpeg).
2. when applying chcon -t textrel_shlib_t /usr/lib/libx264.so.54 everything works
3.
  
Actual results:
programs using libx264 doesn't work without applying chcon on /usr/lib/libx264.so.54

Expected results:
programs should work ouf of the box

Additional info:

Comment 1 Daniel Walsh 2006-11-07 18:38:25 UTC
Fixed in selinux-policy-2.4.3-2

Comment 2 Daniel Walsh 2007-08-22 14:11:40 UTC
Fixed in current release


Note You need to log in before you can comment on or make changes to this bug.