Bug 214422 - Crash upon on adding new entry
Crash upon on adding new entry
Status: CLOSED DUPLICATE of bug 212312
Product: Fedora
Classification: Fedora
Component: revelation (Show other bugs)
6
All Linux
medium Severity medium
: ---
: ---
Assigned To: Thorsten Leemhuis
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-11-07 10:54 EST by Brad Smith
Modified: 2007-11-30 17:11 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-11-07 11:35:45 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Brad Smith 2006-11-07 10:54:49 EST
Description of problem:
When I add a new entry to revelation, it crashes with the following trace:

Traceback (most recent call last):
  File "/usr/bin/revelation", line 266, in <lambda>
    self.tree.selection.connect("changed", lambda w:
self.__state_entry(self.tree.get_selected()))
  File "/usr/bin/revelation", line 305, in __state_entry
    e = self.entrystore.get_entry(iter)
  File "/usr/lib/python2.4/site-packages/revelation/data.py", line 400, in get_entry
    e = self.get_value(iter, COLUMN_ENTRY)
  File "/usr/lib/python2.4/warnings.py", line 61, in warn
    warn_explicit(message, category, filename, lineno, module, registry)
  File "/usr/lib/python2.4/warnings.py", line 82, in warn_explicit
    for item in filters:
TypeError: unknown type (null)


Version-Release number of selected component (if applicable):
0.4.7-5

How reproducible:
Always

Steps to Reproduce:
1. Click "new"
2. Enter a name for the entry and a pw (I rarely use other fields)
3. Click "Update"
  
Actual results:
"Unknown Error" window pops up. If you click Continue you can see the the entry
is saved. In fact, everything works ok except that every time that entry is
clicked, including on subsequent runs of Revelation, the error above still pops
up. Afterward you can view the entry. I assume this is Revelation not dealing
well with blank fields. 


Expected results:
Same, but without the "crash". =;)

Additional info:
Comment 1 Thorsten Leemhuis 2006-11-07 11:35:45 EST
install pygtk2 from updates testing to fix it

*** This bug has been marked as a duplicate of 212312 ***

Note You need to log in before you can comment on or make changes to this bug.