Bug 2144336 - F38FailsToInstall: mlpack-bin, mlpack-devel, mlpack-python3
Summary: F38FailsToInstall: mlpack-bin, mlpack-devel, mlpack-python3
Alias: None
Product: Fedora
Classification: Fedora
Component: mlpack
Version: rawhide
Hardware: Unspecified
OS: Unspecified
Target Milestone: ---
Assignee: Ryan Curtin
QA Contact: Fedora Extras Quality Assurance
Depends On:
Blocks: F38FailsToInstall
TreeView+ depends on / blocked
Reported: 2022-11-20 20:54 UTC by Miro Hrončok
Modified: 2022-11-22 18:18 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Last Closed: 2022-11-22 18:18:48 UTC
Type: ---

Attachments (Terms of Use)

Description Miro Hrončok 2022-11-20 20:54:07 UTC

Please note that this comment was generated automatically. If you feel that this output has mistakes, please contact me via email (mhroncok).

Your package (mlpack) Fails To Install in Fedora 38:

can't install mlpack-bin:
  - nothing provides mlpack(x86-64) = 4.0.0-6.fc38 needed by mlpack-bin-4.0.0-6.fc38.x86_64
can't install mlpack-devel:
  - nothing provides mlpack(x86-64) = 4.0.0-6.fc38 needed by mlpack-devel-4.0.0-6.fc38.x86_64
can't install mlpack-python3:
  - nothing provides mlpack(x86-64) = 4.0.0-6.fc38 needed by mlpack-python3-4.0.0-6.fc38.x86_64
If you know about this problem and are planning on fixing it, please acknowledge so by setting the bug status to ASSIGNED. If you don't have time to maintain this package, consider orphaning it, so maintainers of dependent packages realize the problem.

If you don't react accordingly to the policy for FTBFS/FTI bugs (https://docs.fedoraproject.org/en-US/fesco/Fails_to_build_from_source_Fails_to_install/), your package may be orphaned in 8+ weeks.

P.S. The data was generated solely from koji buildroot, so it might be newer than the latest compose or the content on mirrors. To reproduce, use the koji/local repo only, e.g. in mock:

    $ mock -r fedora-38-x86_64 --config-opts mirrored=False install mlpack-bin mlpack-devel mlpack-python3

P.P.S. If this bug has been reported in the middle of upgrading multiple dependent packages, please consider using side tags: https://docs.fedoraproject.org/en-US/fesco/Updates_Policy/#updating-inter-dependent-packages


Comment 1 Benson Muite 2022-11-21 03:39:52 UTC
mlpack is no longer a required dependency of mlpack-bin, mlpack-python or mlpack-devel. Got this error when upgrading, but removing mlpack and then doing a clean install worked.

Comment 2 Benson Muite 2022-11-21 03:56:08 UTC
Tried this on a newly setup Fedora 37 instance, and mlpack-bin installs ok.  The problem seems to only occur when upgrading.

Comment 3 Benson Muite 2022-11-21 04:38:54 UTC
mock -r fedora-38-x86_64 --config-opts mirrored=False install mlpack-bin mlpack-devel mlpack-python3
fails with error you have above.

Pull request with fix

Comment 4 Ryan Curtin 2022-11-22 18:18:48 UTC
mlpack-4.0.0-7 fixes this.  Thanks Benson!

Note You need to log in before you can comment on or make changes to this bug.