Bug 214456 - avahi exits when scanning ports with nmap
avahi exits when scanning ports with nmap
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: avahi (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Martin Bacovsky
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-11-07 13:26 EST by Mephisto
Modified: 2007-11-30 17:11 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-03-14 11:35:17 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Mephisto 2006-11-07 13:26:53 EST
Description of problem:
When i run a udp port scan with nmap (using the following command: nmap -sU -p
1-65535 localhost), avahi exits. The avahi daemon will show up in the scan
results, but the process will be gone after the scan.

Version-Release number of selected component (if applicable):
avahi-0.6.11-6.fc6

How reproducible:
always

Steps to Reproduce:
1. install avahi and nmap
2. run avahi-daemon
3. run: nmap -sU -p 1-65535 localhost
  
Actual results:
The avahi daemon has crashed or otherwise shut down.

Expected results:
The daemon should still be running like nothing has happened.

Additional info:
Comment 1 Mephisto 2006-11-07 13:29:17 EST
Btw, i have not tested this from a remote host, since the avahi port seems
random to me, and running an nmap scan over all ports takes a very long time.
Comment 2 Martin Bacovsky 2007-03-14 11:35:17 EDT
In current version (avahi-0.6.17-1.fc7) it seems working. If you still are able
to reproduce the bug feel free to reopen this bug

Note You need to log in before you can comment on or make changes to this bug.