Bug 2144614 - sendmail does not start authentication process or does not accept authentication
Summary: sendmail does not start authentication process or does not accept authentication
Keywords:
Status: CLOSED DUPLICATE of bug 2140596
Alias: None
Product: Fedora
Classification: Fedora
Component: sendmail
Version: 37
Hardware: x86_64
OS: Linux
unspecified
high
Target Milestone: ---
Assignee: Jaroslav Škarvada
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2022-11-21 21:05 UTC by Helmut K. C. Tessarek
Modified: 2022-11-22 00:50 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2022-11-22 00:40:47 UTC
Type: Bug


Attachments (Terms of Use)
sendmail.mc (2.60 KB, text/plain)
2022-11-21 21:05 UTC, Helmut K. C. Tessarek
no flags Details

Description Helmut K. C. Tessarek 2022-11-21 21:05:30 UTC
Created attachment 1926216 [details]
sendmail.mc

Created attachment 1926216 [details]
sendmail.mc

Description of problem:

After upgrading from F36 to F37, sending emails was no longer possible. Sendmail did not start the authentication process and/or did not accept user/password any longer.

I have been using my sendmail.mc for the past 10 years and it worked perfectly until I upgraded to F37.

Turns out that the following directive breaks the sending functionality (authenticated submission via implicit TLS):

define(`confAUTH_OPTIONS', `A p y')`

After changing it to

define(`confAUTH_OPTIONS', `p y')`

sendmail starts working again.

Version-Release number of selected component (if applicable):

sendmail-8.17.1-6.fc37.x86_64

How reproducible:


Steps to Reproduce:
1. setup sendmail to send emails via submissions on 465 with authentication
2. send email

Actual results:

Error message: Relaying denied. Proper authentication required.
Server logs show that authentication was not even initiated.

Expected results:

The client should authenticate against the server and the mail should be sent.

Additional info:

The mail client is irrelevant. I haven't changed it for a long time (not even upgraded it, since I need its functionality that was removed with a later version), but I have also tried other (newer and most recent) mail cilents.

For completeness I will attach my sendmail.mc (even though I don't think it will help, except for you to see that I didn't screw up my config.)

Comment 1 Jaroslav Škarvada 2022-11-22 00:40:47 UTC

*** This bug has been marked as a duplicate of bug 2140596 ***

Comment 2 Helmut K. C. Tessarek 2022-11-22 00:50:27 UTC
Interesting. testsaslauthd works just fine (which is something I forgot to mention in my bug report), so I guess sendmail's integration with SASL is borked and not sasl itself.


Note You need to log in before you can comment on or make changes to this bug.