Bug 2144808 - When starting fedora a problem occurs, when viewing the problem setroubleshoot quits unexpectedly, commandline /usr/bin/python3 -Es /usr/bin/seapplet
Summary: When starting fedora a problem occurs, when viewing the problem setroubleshoo...
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Fedora
Classification: Fedora
Component: satyr
Version: 37
Hardware: x86_64
OS: Linux
unspecified
unspecified
Target Milestone: ---
Assignee: Michal Fabik
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On: 2144797
Blocks:
TreeView+ depends on / blocked
 
Reported: 2022-11-22 11:19 UTC by Petr Lautrbach
Modified: 2022-11-23 08:48 UTC (History)
12 users (show)

Fixed In Version: satyr-0.40-1.fc37
Doc Type: If docs needed, set a value
Doc Text:
Clone Of: 2144797
Environment:
Last Closed: 2022-11-22 11:27:51 UTC
Type: Bug


Attachments (Terms of Use)

Description Petr Lautrbach 2022-11-22 11:19:30 UTC
+++ This bug was initially created as a clone of Bug #2144797 +++

Description of problem:

setroubleshoot quit unexpectedly (Misbehaviour)
2022-11-21-13:24:02> Server responded with an error: 'Element 'exception_name' is invalid: String '  File "/usr/bin/seapplet", line 68, in __init__' does not match the pattern  '^[a-zA-Z0-9_\.]+$''
2022-11-21-13:24:02* ('report_uReport' exited with 1)
2022-11-21-13:25:13> Server responded with an error: 'Element 'exception_name' is invalid: String '  File "/usr/bin/seapplet", line 68, in __init__' does not match the pattern  '^[a-zA-Z0-9_\.]+$''
2022-11-21-13:25:13* ('report_uReport' exited with 1)
2022-11-22-10:59:44> ('report_uReport' completed successfully)
2022-11-22-10:59:45> Looking for similar problems in bugzilla
2022-11-22-10:59:45  fatal: RPC failed at server.  The API key you specified is invalid. Please check that you typed it correctly.
2022-11-22-10:59:45  abrt-action-find-bodhi-update [ERROR] Search for duplicate bugs failed: None
2022-11-22-10:59:45* ('analyze_BodhiUpdates' exited with 2)
Version-Release number of selected component (if applicable):

3.3.30-2.fc37
How reproducible:
Start Fedora

Steps to Reproduce:
1.Start Fedora37
2.Warning appears that a problem occured
3.Click to show the problem

Actual results:

setroubleshoot quit unexpectedly
Expected results:
should be able to report a problem

Additional info:
https://ask.fedoraproject.org/t/setroubleshoot-quit-unexpectedly/28954 
https://retrace.fedoraproject.org/faf/reports/543934/

--- Additional comment from Petr Lautrbach on 2022-11-22 12:18:31 CET ---

It looks like:

1. seapplet called dasbus get_proxy() and it failed for some reason
2. abort tried to report the problem and it failed

Comment 1 Michal Srb 2022-11-22 11:27:51 UTC
Please make sure that you have the latest satyr-0.40-1.fc37 installed:
https://bodhi.fedoraproject.org/updates/FEDORA-2022-2a370286a6

Note since the data that ABRT is trying to report has been generated with the older
version of the library, you may need to rerun the "abrt-action-analyze-python"
command in the problem directory to regenerate the data:

# cd /var/spool/abrt/Python3-.../
# abrt-action-analyze-python -d .

Comment 2 Peter Braet 2022-11-23 08:48:29 UTC
Thank you for the tip.
satyr-0.40-1.fc37 was already installed, installing python3-satyr-0.40-1.fc37 seems to have solved the problem.
For some reason python3-satyr-0.40-1.fc37 was not installed while upgrading from fc36 to fc37.
When ever a real problem occurs I will see if the reporting works now.


Note You need to log in before you can comment on or make changes to this bug.