Bug 214493 - Boxes printed instead of zero-width characters
Boxes printed instead of zero-width characters
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: libgnomeprint22 (Show other bugs)
6
All Linux
medium Severity medium
: ---
: ---
Assigned To: David Zeuthen
: Desktop, i18n
Depends On:
Blocks: 218557
  Show dependency treegraph
 
Reported: 2006-11-07 15:58 EST by Behdad Esfahbod
Modified: 2013-03-05 22:47 EST (History)
2 users (show)

See Also:
Fixed In Version: libgnomeprint22-2.17.0-2.fc7
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-01-16 06:34:15 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
The box chacters appearing in hi_IN while firing a print. (51.95 KB, application/postscript)
2007-01-16 06:24 EST, Ramakrishna Reddy Yekulla
no flags Details
The correct version appearing in rawhide (48.53 KB, application/postscript)
2007-01-16 06:29 EST, Ramakrishna Reddy Yekulla
no flags Details


External Trackers
Tracker ID Priority Status Summary Last Updated
GNOME Desktop 330907 None None None Never

  None (edit)
Description Behdad Esfahbod 2006-11-07 15:58:51 EST
I'm sure there is a dupe of this bug already.  Anyway, please either update to a
very recent libgnomeprint or consider including the latest patch in this GNOME bug:

  http://bugzilla.gnome.org/show_bug.cgi?id=330907

Without the patch, gedit and other apps print boxes in many places in Arabic and
Indic languages.
Comment 1 Roozbeh Pournader 2006-11-08 07:22:16 EST
Apparently the latest version is 2.12.1, which rawhide is using:
http://ftp.gnome.org/pub/gnome/sources/libgnomeprint/

I guess we should either ping kmaraas etc to make a release or patch heavily
downstream.
Comment 2 Kjartan Maraas 2006-11-08 07:33:28 EST
I'll make a release today/this week
Comment 3 Behdad Esfahbod 2006-11-14 18:11:26 EST
So, mclasen is telling me that the newly released libgnomeprint22 is in rawhide.
 Can we get that in FC6 too?
Comment 4 Behdad Esfahbod 2006-11-14 18:12:34 EST
Roozbeh, can you test rawhide?
Comment 5 Behdad Esfahbod 2006-12-05 18:05:29 EST
Roozbeh, ping.  Is this fixed in rawhide?
Akira is saying that it's not for Indic.
Comment 6 David Zeuthen 2006-12-07 12:38:38 EST
libgnomeprint22-2.12.1-9.fc6 which includes the patch from the GNOME bug
referenced in comment 1 is pushed to testing.
Comment 7 Akira TAGOH 2006-12-07 22:39:42 EST
(In reply to comment #5)
> Roozbeh, ping.  Is this fixed in rawhide?
> Akira is saying that it's not for Indic.

Well, it seems that the warning messages I saw was caused by another reason.
please see this log:

$ LANG=zh_CN.gb18030 gdb --args gedit Wei.txt 
...
(gdb) start
Breakpoint 1 at 0x806f24e: file gedit.c, line 147.
Starting program: /usr/bin/gedit Wei.txt
[Thread debugging using libthread_db enabled]
[New Thread -1208604976 (LWP 12703)]
[Switching to Thread -1208604976 (LWP 12703)]
main (argc=2, argv=0xbfa49a24) at gedit.c:147
147             if (startup_id_env == NULL)
(gdb) b gnome_rfont_get_glyph_stdadvance
Breakpoint 2 at 0x510b1ad: file gnome-rfont.c, line 595.
(gdb) cond 2 glyph > rfont->font->face->num_glyphs
(gdb) c
Continuing.
...
Breakpoint 2, gnome_rfont_get_glyph_stdadvance (rfont=0x8b6f110, 
    glyph=268437002, advance=0xbfa48d98) at gnome-rfont.c:595
595     {
(gdb) p *rfont->font->face
$1 = {object = {g_type_instance = {g_class = 0x916a480}, ref_count = 15, 
    qdata = 0x0}, entry = 0x91568a0, num_glyphs = 30325, glyphs = 0xb152a008, 
  ft2ps = 3.90625, bbox = {x0 = -3.0720000000000001, y0 = -226.5625, 
    x1 = 1000, y1 = 886.71875}, ft_face = 0x92c6020, fonts = 0x92fe728, 
  psname = 0x92e1700 "ZYSong18030"}

And where 'glyph' come from:
(gdb) b meta_glyphlist 
Breakpoint 3 at 0x50ea65a: file gnome-print-meta.c, line 342.
(gdb) cond 3 gl->glyphs[0] > 100000
(gdb) r
...
Breakpoint 3, meta_glyphlist (pc=0xa020ca8, affine=0xbf8e7ad8, gl=0xa169640)
    at gnome-print-meta.c:342
342             gpm_encode_int (pc, GNOME_META_GLYPHLIST);
(gdb) p gl->glyphs[0]
$2 = 268437002
(gdb) bt
#0  meta_glyphlist (pc=0xa020ca8, affine=0xbf8e7ad8, gl=0xa169640)
    at gnome-print-meta.c:342
#1  0x050dd517 in gnome_print_glyphlist_transform_real (pc=0xa020ca8, 
    a=0xbf8e7ad8, l=0xa169640) at gnome-print.c:387
#2  0x050dd663 in gnome_print_glyphlist_transform (pc=0xa020ca8, 
    affine=0xbf8e7ad8, gl=0xa169640) at gnome-print.c:663
#3  0x050def8a in gnome_print_glyphlist (pc=0xa020ca8, glyphlist=0xa169640)
    at gnome-print-stdapi.c:842
#4  0x050f59ac in gnome_print_pango_glyph_string (gpc=0xa020ca8, 
    font=0xa2bf0e0, glyphs=0xa199b00) at gnome-print-pango.c:320
#5  0x050f5cb5 in print_pango_layout_line (gpc=0xa020ca8, line=0xa1c79e0)
    at gnome-print-pango.c:628
#6  0x0073c91b in print_page (job=0xa071c60) at gtksourceprintjob.c:1527
#7  0x0073cb0e in idle_printing_handler (job=0xa071c60)
    at gtksourceprintjob.c:1631
#8  0x04801a97 in g_source_set_closure () from /lib/libgobject-2.0.so.0
#9  0x047ead8b in g_closure_invoke () from /lib/libgobject-2.0.so.0
#10 0x04801a45 in g_source_set_closure () from /lib/libgobject-2.0.so.0
#11 0x0476b491 in g_source_is_destroyed () from /lib/libglib-2.0.so.0
#12 0x0476d1f2 in g_main_context_dispatch () from /lib/libglib-2.0.so.0
#13 0x047701cf in g_main_context_check () from /lib/libglib-2.0.so.0
#14 0x04770579 in g_main_loop_run () from /lib/libglib-2.0.so.0
#15 0x04b97c24 in IA__gtk_main () at gtkmain.c:1001
---Type <return> to continue, or q <return> to quit---q
Quit
(gdb) frame 5
#5  0x050f5cb5 in print_pango_layout_line (gpc=0xa020ca8, line=0xa1c79e0)
    at gnome-print-pango.c:628
628                     gnome_print_pango_glyph_string (gpc,
run->item->analysis.font, run->glyphs);
(gdb) p run
$3 = (PangoLayoutRun *) 0xa1c8460
(gdb) p run->glyphs->glyphs[0]
$4 = {glyph = 268437002, geometry = {width = 9216, x_offset = 0, 
    y_offset = 0}, attr = {is_cluster_start = 1}}

So weird things was from Pango. FYI
Comment 8 Behdad Esfahbod 2006-12-08 12:17:34 EST
268437002 is 0x1000060a, which is a hexbox for the character U+060A.  Right, my
patch doesn't handle hexboxes I guess.  I can make it simply skip hexboxes if
that helps.
Comment 9 Fedora Update System 2006-12-15 17:05:25 EST
libgnomeprint22-2.12.1-9.fc6 has been pushed for fc6, which should resolve this issue.  If these problems are still present in this version, then please make note of it in this bug report.
Comment 10 Fedora Update System 2007-01-02 14:31:31 EST
libgnomeprint22-2.12.1-9.fc6 has been pushed for fc6, which should resolve this issue.  If these problems are still present in this version, then please make note of it in this bug report.
Comment 11 Ramakrishna Reddy Yekulla 2007-01-16 06:24:33 EST
Created attachment 145672 [details]
The box chacters appearing in hi_IN while firing a print.

tested against the following version
[root@vanilla ~]# rpm -qa |grep libgnomeprint
libgnomeprint22-2.12.1-8
libgnomeprintui22-devel-2.12.1-6
libgnomeprintui22-2.12.1-6
libgnomeprint22-devel-2.12.1-8
Comment 12 Ramakrishna Reddy Yekulla 2007-01-16 06:29:30 EST
Created attachment 145674 [details]
The correct version appearing in rawhide

Tested in rawhide...
Version number :;
libgnomeprint22-2.17.0-2.fc7
have attached the corrected version of the sequence. Works fine in hindi too.

Note You need to log in before you can comment on or make changes to this bug.