Bug 214519 - pkg-config should process recursively Requires.static
pkg-config should process recursively Requires.static
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: pkgconfig (Show other bugs)
6
All Linux
medium Severity medium
: ---
: ---
Assigned To: Matthias Clasen
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-11-07 17:38 EST by Patrice Dumas
Modified: 2007-11-30 17:11 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-03-30 01:43:38 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
FreeDesktop.org 8788 None None None Never

  None (edit)
Description Patrice Dumas 2006-11-07 17:38:51 EST
Description of problem:

pkg-config --libs --static should take into account Requires.static
recursively. For example if one have, in the .pc file 

Libs: -L${libdir} -ltests
Requires.private: x11

One get:
$ pkg-config --static --libs tests
-ltests -lX11 -lpthread

While, there is
$ pkg-config --static --libs x11
-lX11 -lpthread -lXau -lXdmcp

One should have
$ pkg-config --static --libs tests
-ltests -lX11 -lpthread -lXau -lXdmcp

in the x11.pc there is
Requires.private: xau xdmcp
Libs.private: -lpthread

so -lpthread is taken into account, while Requires.private are
not taken into account.

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:
Comment 1 Matthias Clasen 2007-01-24 10:09:28 EST
True, but do we want to encourage static linking by fixing this ?
Comment 2 Rex Dieter 2007-01-24 10:12:28 EST
It's the opposite, imo.  dynamic linking is harmed/influenced by
static-link-only bits in .pc files (without the patch)
Comment 3 Rex Dieter 2007-01-24 10:13:13 EST
oops, ignore me, brain still stuck on last bug submitted wrt pkg-config. (:
Comment 4 Rex Dieter 2007-01-24 10:17:59 EST
Seems to be reported upstream:
https://bugs.freedesktop.org/show_bug.cgi?id=8788
with (unverified) patch.
Comment 5 Matthias Clasen 2007-03-30 01:43:38 EDT
Fixed in 0.21-5.fc7

Note You need to log in before you can comment on or make changes to this bug.