Bug 214545 - Filenames on DVDs by nautilus-cd-burner incompatible with e.g. Windows
Filenames on DVDs by nautilus-cd-burner incompatible with e.g. Windows
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: nautilus-cd-burner (Show other bugs)
6
All Linux
medium Severity high
: ---
: ---
Assigned To: Alexander Larsson
http://bugzilla.gnome.org/show_bug.cg...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-11-07 22:51 EST by E Mair
Modified: 2007-11-30 17:11 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-11-10 10:12:20 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description E Mair 2006-11-07 22:51:45 EST
Description of problem:
nautilus-cd-burner creates "on the fly" data DVDs with filenames getting
truncated to 8.3 format when read by (at least) Windows.

Version-Release number of selected component (if applicable):
nautilus-cd-burner-2.16.0-3.fc6

How reproducible:
Always

Steps to Reproduce:
1. Add a file like "Long filename with intërnätionål characters.doc" to the
CD/DVD creator. Burn a DVD.
2. See the original filenames being displayed correctly on the DVD with Fedora.
3. Give DVD to Windows using colleague or anyone from the vast majority of
computer users and wait for them asking what the h*ll you're playing at, and
what "LONG____.DOC" is. ;)
  
Actual results:
All filenames are truncated to ALL CAPS 8.3 format when the DVD is read in e.g.
Windows.

Expected results:
The data should be unchanged; the original filenames should be accessible by
Windows too.

Additional info:
This (missing Joliet support?) has been patched upstream, see
http://bugzilla.gnome.org/show_bug.cgi?id=359997

Please release a patched Fedora RPM asap. I set severity to High because this
effectively makes nautilus-cd-burner's DVD feature useless, unless one only
intends to use the DVDs on Linux systems.
I made a bunch of back-up DVDs, only to later find out that they're useless in
the OS I would have to temporarily resort to in case I should actually need the
back-ups...
Comment 1 Alexander Larsson 2006-11-09 05:21:32 EST
nautilus-cd-burner-2.16.0-5.fc6 has been pushed as a testing update. Can you
verify that it works?
Comment 2 E Mair 2006-11-10 09:55:33 EST
Yes, it's working now. Thanks!

(I don't know if I'm supposed to close the bug now, or if you'll do that once
the fix has been pushed as a regular update?)
Comment 3 Alexander Larsson 2006-11-10 10:12:20 EST
I'll close it. It'll be moved to final later.

Note You need to log in before you can comment on or make changes to this bug.