Bug 214568 - maxima: sbcl unhandled condition in --disable-debugger mode
maxima: sbcl unhandled condition in --disable-debugger mode
Status: CLOSED NEXTRELEASE
Product: Fedora
Classification: Fedora
Component: maxima (Show other bugs)
5
All Linux
medium Severity medium
: ---
: ---
Assigned To: Rex Dieter
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-11-08 07:37 EST by Leo
Modified: 2007-11-30 17:11 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-11-14 08:45:40 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Leo 2006-11-08 07:37:29 EST
Description of problem:
Maxima with sbcl runtime is unstable. It exits abnormally very often.
For more detail please see:
http://permalink.gmane.org/gmane.comp.mathematics.maxima.general/12706

Version-Release number of selected component (if applicable):
The latest in FC5 (5.10.0) with sbcl runtime.

How reproducible:
100%

Steps to Reproduce:
1. Fire up maxima
2. to_lisp();
3. (kdkdkd)
  
Actual results:


Expected results:


Additional info:
Comment 1 Rex Dieter 2006-11-10 10:08:27 EST
Can you confirm the problem with the latest maxima/sbcl builds:
sbcl-0.9.18-1.fc5
maxima-5.10.0-7.fc5

(I can't seem to reproduce this)
Comment 2 Leo 2006-11-10 11:07:46 EST
With the latest versions of maxima and sbcl, the error still happens.

MAXIMA> (kkkd)

; in: LAMBDA NIL
;     (MAXIMA::KKKD)
;
; caught STYLE-WARNING:
;   undefined function: KKKD

;
; caught STYLE-WARNING:
;   This function is undefined:
;     KKKD
;
; compilation unit finished
;   caught 2 STYLE-WARNING conditions
unhandled SIMPLE-ERROR in thread #<SB-THREAD:THREAD "initial thread" {9004501}>:
  Error during processing of --eval option "(cl-user::run)":

  The function KKKD is undefined.

0: (SB-DEBUG:BACKTRACE 128 #<SYNONYM-STREAM :SYMBOL SB-SYS:*STDERR* {5074CD1}>)
1: (SB-DEBUG::DEBUGGER-DISABLED-HOOK
    #<SIMPLE-ERROR {95FD991}>
    #<unavailable argument>)
2: (INVOKE-DEBUGGER #<SIMPLE-ERROR {95FD991}>)
3: (ERROR
    "Error during processing of --eval ~
                                    option ~S:~%~%  ~A")
4: ((LAMBDA (SB-IMPL::E)) #<UNDEFINED-FUNCTION KKKD {95FD8F1}>)
5: ((LAMBDA (SB-IMPL::E)) #<UNDEFINED-FUNCTION KKKD {95FD8F1}>)
6: (SIGNAL #<UNDEFINED-FUNCTION KKKD {95FD8F1}>)
7: (ERROR UNDEFINED-FUNCTION)
8: (SB-KERNEL::UNDEFINED-FUN-ERROR-HANDLER
    #<unavailable argument>
    #.(SB-SYS:INT-SAP #XB7BA79E4)
    #<SB-ALIEN-INTERNALS:ALIEN-VALUE :SAP #XB7BA76CC :TYPE (*
                                                            (SB-ALIEN:STRUCT
                                                             SB-VM::OS-CONTEXT-T
-STRUCT))>
    (14))
9: (SB-KERNEL:INTERNAL-ERROR
    #.(SB-SYS:INT-SAP #XB7BA76CC)
    #<unavailable argument>)
10: ("foreign function: call_into_lisp")
11: ("foreign function: funcall2")
12: ("foreign function: interrupt_internal_error")
13: ("foreign function: sigtrap_handler")
14: ("bogus stack frame")
15: (SB-INT:SIMPLE-EVAL-IN-LEXENV (KKKD) #<NULL-LEXENV>)
16: (MAXIMA-READ-EVAL-PRINT-LOOP)
17: (MAXIMA-READ-EVAL-PRINT-LOOP)
18: ($TO_LISP)
19: (MEVAL1 #<unavailable argument>)
20: (MEVAL (($TO_LISP)))
21: (MEVAL* (($TO_LISP)))
22: (TOPLEVEL-MACSYMA-EVAL (($TO_LISP)))
23: (CONTINUE #<SYNONYM-STREAM :SYMBOL SB-SYS:*STDIN* {5026CE1}> NIL)
24: (MACSYMA-TOP-LEVEL #<SYNONYM-STREAM :SYMBOL SB-SYS:*STDIN* {5026CE1}> NIL)
25: (RUN)
26: (SB-INT:SIMPLE-EVAL-IN-LEXENV (RUN) #<NULL-LEXENV>)
27: (SB-IMPL::PROCESS-EVAL-OPTIONS ("(cl-user::run)"))
28: (SB-IMPL::TOPLEVEL-INIT)
29: ((LABELS SB-IMPL::RESTART-LISP))

unhandled condition in --disable-debugger mode, quitting
Returning to Maxima
Comment 3 Rex Dieter 2006-11-10 11:15:40 EST
OK, gotcha.  I have one idea... lemme see if that helps.
Comment 4 Rex Dieter 2006-11-10 13:51:03 EST
This is likely caused because we patch the maxima build to use
sbcl --disable-debugger
to prevent any rpmbuild process from hanging (waiting on sbcl's interactive
debugger).

From reading sbcl's manpage, it appears this bahavior will persist in any
sbcl-created image, ugh.

Comment 5 Leo 2006-11-10 14:01:00 EST
I think that's the reason.

Are you building the maxima and maxima-sbcl-runtime on your own machine or is
there a dedicated server for extras package building?

Because other distributions seem to handle this well.

Comment 6 Rex Dieter 2006-11-10 14:07:34 EST
> Are you building the maxima and maxima-sbcl-runtime on your own machine or is
> there a dedicated server for extras package building?

The latter.

I'm trying to make maxima build without sbcl --disable-debugger, but wouldn't ya
know, it's getting stuck somewhere (and hanging on the interactive debugger).
Comment 7 Rex Dieter 2006-11-14 08:45:40 EST
This should do the trick.

%changelog
* Fri Nov 10 2006 Rex Dieter <rexdieter[AT]users.sf.net> 5.10.0-8
- omit sbcl-disable-debugger patch (#214568)
Comment 8 Leo 2006-11-14 19:40:46 EST
Where can I find the updated version?
Comment 9 Rex Dieter 2006-11-14 21:04:19 EST
The new build should appear in Extras repo real soon (usually within 24-48 
hours).
Comment 10 Leo 2006-11-14 21:29:08 EST
I confirm the bug is fixed. Thanks a lot, Rex.

Note You need to log in before you can comment on or make changes to this bug.