Bug 21464 - php-imap, php-ldap, php-manual, php-pgsql rpmlib dependancy
php-imap, php-ldap, php-manual, php-pgsql rpmlib dependancy
Status: CLOSED NOTABUG
Product: Red Hat Linux
Classification: Retired
Component: php (Show other bugs)
6.2
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Nalin Dahyabhai
Dale Lovelace
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2000-11-28 22:12 EST by Wenzhuo Zhang
Modified: 2007-04-18 12:30 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2000-11-30 08:57:35 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Wenzhuo Zhang 2000-11-28 22:12:31 EST
These four packages in ftp://updates.redhat.com/6.2 have the rpmlib
dependancy:
rpmlib(VersionedDependencies) <= 3.0.3-1
which, I think, is wrong.

rpmlib(VersionedDependencies) <= 3.0.3-1
--> php-imap-3.0.17-1.6.2.i386.rpm
rpmlib(VersionedDependencies) <= 3.0.3-1
--> php-ldap-3.0.17-1.6.2.i386.rpm
rpmlib(VersionedDependencies) <= 3.0.3-1
--> php-manual-3.0.17-1.6.2.i386.rpm
rpmlib(VersionedDependencies) <= 3.0.3-1
--> php-pgsql-3.0.17-1.6.2.i386.rpm

This causes dependancy problems when installing redhat from a cdrom with
all the updates merged in. The installation program says the four packages
haven't been selected when doing dependancy checking, even on a full
installation.
Comment 1 Bill Nottingham 2000-11-30 00:46:34 EST
It's correct. That dependency is satisfied by the errata rpm RPM.
Comment 2 Wenzhuo Zhang 2000-11-30 08:57:32 EST
Why do those four packages require RPMLIB VERSION 3.03 OR EARLIER? Also, as I
remember, the stock redhat 6.2 ships with rpm 3.04, which obviously doesn't
satisfy the php packages' dependacies.

Well, it doesn't matter much. But it makes makes the installation from an
updated redhat CD a little bit ugly.
Comment 3 Nalin Dahyabhai 2000-11-30 09:56:24 EST
The updated package of RPM 3.0.5 itself is also available in the same directory
.  The specific way RPM prints out the dependency syntax (the "<=" isn't stored
in the database, it's a bitfield with one bit for "<" and one bit for "=") is
more than I know about RPM's internals, though.
Please check the errata notice at
http://www.redhat.com/support/errata/RHEA-2000-051-01.html for more details.
Comment 4 Wenzhuo Zhang 2000-11-30 21:58:55 EST
It looks that the problem is caused by the installer not being able to recognize
the rpmlib dependancies. If the new updates require rpmlib dependancy, why don't
you upgrade the installers too? It's a compatibility issue.

Note You need to log in before you can comment on or make changes to this bug.