Bug 214658 - XFS problems with LVM
XFS problems with LVM
Status: CLOSED DUPLICATE of bug 212201
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
6
All Linux
medium Severity medium
: ---
: ---
Assigned To: Kernel Maintainer List
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-11-08 14:33 EST by Chris Weyl
Modified: 2007-11-30 17:11 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-11-15 23:27:40 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Chris Weyl 2006-11-08 14:33:44 EST
Description of problem:
Installing FC6 with XFS instead of ext3 yeilds filesystem issues after the install.

Version-Release number of selected component (if applicable):
FC6, base kernel & xfsprogs.

How reproducible:
Install FC6 system with defaults, _except_ substitute xfs for ext3 as the file
system on all non-/boot partitions.
 
Actual results:
Post-mounting of filesystems, kernel messages spew across the screen:

<1>I/O error in filesystem("dm-0") meta-data dev dm-0 block 0x2abb8000000
("xfs_trans_read_buf") error 5 buf count 4096
<6>attempt to access beyond end of device
<6>dm-0: rw=0, want=2936549670920, limit=12255323

Repeated multitudes of times.  These messages were captured by rebooting
installer in rescue mode.

Note that the filesystems appear to mount cleanly, and minor operations (e.g.
"cat etc/fstab") work.

The end system is unusable :(

Expected results:
Spiffy new FC6 system with xfs goodness.

Additional info:
Note this does not appear to happen on FC5 systems with lvm/xfs upgraded to FC6.
Comment 1 Chris Weyl 2006-11-08 16:01:26 EST
On the fourth attempt, I rebooted into the installers rescue mode and
xfs_check'ed the three xfs filesystems (/, /tmp. /home).  The root fs was
seriously corrupted; xfs_repair was unable to fix.  

Recreating these filesystems from within the rescue shell with mkfs.xfs
(sticking with all defaults except labeling (-L) each fs) and reinstalling w/o
reformatting yielded a working FC6 system.

I don't know if this was a one-off (in which case I'll be a touch embarassed) or
if this was indeed a bug.
Comment 2 Eric Sandeen 2006-11-15 23:27:40 EST
problems w/ the mkfs command in anaconda for some very strange reason... duping
to bug w/ more info.

*** This bug has been marked as a duplicate of 212201 ***

Note You need to log in before you can comment on or make changes to this bug.