Bug 21469 - br-abnt2 on console won't accept slash/question mark
br-abnt2 on console won't accept slash/question mark
Status: CLOSED CURRENTRELEASE
Product: Red Hat Linux
Classification: Retired
Component: console-tools (Show other bugs)
7.3
i386 Linux
high Severity medium
: ---
: ---
Assigned To: Eido Inoue
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2000-11-29 02:17 EST by Alexandre Oliva
Modified: 2007-03-26 23:37 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-08-23 16:29:43 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Alexandre Oliva 2000-11-29 02:17:55 EST
On *some* (not all) ABNT2 keyboards, the keymap br-abnt2 will simply ignore
the key that generates the forward slash and the question mark, when in
console mode.  XFree86 handle all ABNT2 keyboards correctly.

After adding the following two lines to the keymap file, the keyboard
starts working correctly:

keycode  89 = slash question
	alt		keycode  89 = Meta_slash

While I was at it, I noticed `alt keycode 86' gets me a Meta_less.  I
wonder why it doesn't generate a Meta_backslash.  Also, it seems to me
that `control keycode 86' should generate a Control_backslash.  Here
are the relevant modified lines:

keycode  86 = backslash bar
	control		keycode  86 = Control_backslash
	alt		keycode  86 = Meta_backslash

Hope this helps.
Comment 1 Bernhard Rosenkraenzer 2001-01-17 09:09:39 EST
Done in -31.
No idea why it was wrong in the first place - I've never seen an ABNT2 keyboard,
so I have to rely on whatever was in the console-tools tarball.
Comment 2 Alexandre Oliva 2001-04-17 20:32:30 EDT
The fix didn't make it to the installer.  And, indeed, the graphical installer
seems to get an even worse kbd map: none of the slash keys work.  After a text
install and setting up the kbd type in XF86Config-4 with:
 	Option      "XkbModel"  "abnt2"
	Option      "XkbLayout" "br"
	Option      "XkbVariant" "nodeadkeys"
both slash keys work, so it's something specific to the installer too.

Comment 3 Alexandre Oliva 2001-10-25 16:52:12 EDT
I'm afraid the fix didn't make it to the 7.2 installer (bootnet floppy and
CD-ROM tested).  After installation is complete, or during an X install, the
slash works correctly, but befor getting to X in a net install, entering the NFS
mount-point is a pain :-(  Ditto for mounting stuff in rescue mode :-(

Please make sure the correct abnt2 text-mode kbd setup makes it to the installer
for the next release, and if we ever find a better reason to release new
installer images, please consider getting the fix into it.

Sorry for not catching this in the betas.  I try to stay away from ABNT2
keyboards, but it seems like I'm going to have to get used to it.
Comment 4 Alexandre Oliva 2002-07-01 01:04:11 EDT
Problem still present in 7.3's installer and rescue disks: the slash key does
not work in text mode, which makes it an interesting exercise to enter
pathnames.  Is there anything I can do to help make sure this fix makes it to
the next release?
Comment 5 Eido Inoue 2004-08-23 16:29:43 EDT
Based on what I know about pt and the current kbd, the slash should
work now.
Comment 6 Alexandre Oliva 2004-08-23 17:10:06 EDT
It has worked for quite some time, indeed, but I just got a confusing
report from an acquaintance that uses such a keyboard, and he reports
the slash has stopped working very recently, when he installed FC2 (or
was it FC3test1).  I asked him to file a bug report, specifying
whether the problem was in text or X mode, but he hasn't done so yet.
 We can probably leave this bug closed.
Comment 7 Alexandre Oliva 2004-08-23 17:11:10 EDT
I failed to mention that, for personal experience, FC2 works with
br-abnt2 out of the box.  I just meant to mention that there may be
some recent regression related with it.

Note You need to log in before you can comment on or make changes to this bug.