Bug 214720 - Latest Firefox update breaks Galeon
Latest Firefox update breaks Galeon
Status: CLOSED NEXTRELEASE
Product: Fedora
Classification: Fedora
Component: galeon (Show other bugs)
6
All Linux
medium Severity high
: ---
: ---
Assigned To: Denis Leroy
Fedora Extras Quality Assurance
: Reopened
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-11-08 18:59 EST by E Mair
Modified: 2007-11-30 17:11 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-12-22 02:48:35 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description E Mair 2006-11-08 18:59:15 EST
Description of problem:
Installing firefox-1.5.0.8-1.fc6 will stop Galeon from starting.

Version-Release number of selected component (if applicable):
firefox-1.5.0.8-1.fc6
galeon-2.0.3-3.fc6

How reproducible:
Always

Steps to Reproduce:
1. Install latest update of Firefox
2. Try to run Galeon
  
Actual results:
Galeon will not start.

"galeon: error while loading shared libraries: libgtkembedmoz.so: cannot open
shared object file: No such file or directory"

Expected results:

Galeon should start.

Additional info:
Comment 1 Denis Leroy 2006-11-09 06:00:42 EST
Already fixed and rebuild, will be available at the next Fedora Extras push.
Comment 2 Remi Collet 2006-11-09 11:13:15 EST
I think galeon should (as epihany, yelp and others does) require exact version
for gecko-libs.

From yelp.spec
%define gecko_version 1.8.0.8
...
Requires: gecko-libs = %{gecko_version}
...
BuildRequires: gecko-devel = %{gecko_version}

In this way, next firefox update will not break galeon but will only block
updates until new galeon is ready.
Comment 3 Denis Leroy 2006-11-09 17:43:04 EST
Good point, we're hitting a limitation of the rpm automatic dependencies
detection system here, and of course firefox non-standard dynamic libraries
versioning.

Comment 4 E Mair 2006-12-21 23:14:55 EST
Same thing again with FF 1.5.0.9.
Comment 5 Denis Leroy 2006-12-22 02:48:35 EST
Fixed already, at next FE push.



Note You need to log in before you can comment on or make changes to this bug.