Bug 214744 - Installation can not be completed due to an error with message "An error occured unmounting the CD...."
Installation can not be completed due to an error with message "An error occu...
Status: CLOSED DUPLICATE of bug 212018
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
6
i386 Linux
medium Severity urgent
: ---
: ---
Assigned To: Anaconda Maintenance Team
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-11-09 00:21 EST by Shashank Likhite
Modified: 2008-08-02 19:40 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-03-23 14:49:31 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Shashank Likhite 2006-11-09 00:21:20 EST
Description of problem:
Installation can not be completed due to an error with message "An error 
occured unmounting the CD...."

Version-Release number of selected component (if applicable):
Fedora core 6

How reproducible:
Guranteedly reproducible

Steps to Reproduce:
1. Download Fedora core 6, burn DVD
2. Start installing Fedora core 6 on a PC
3. After selecting language etc options (select all default options), the 
point where it should start installing components, it stucks with following 
error message --

An error occured unmounting the CD. Please make sure you're not 
accessing /mnt/source from shell on tty2 and then click OK to retry.
  
Actual results:

Installation stucks with following error message --

An error occured unmounting the CD. Please make sure you're not 
accessing /mnt/source from shell on tty2 and then click OK to retry.

Expected results:

Continued installation

Additional info:
Comment 1 Jeremy Katz 2006-11-09 11:30:34 EST
Can you switch to tty2 and grab /tmp/syslog and /tmp/anaconda.log?  Did you
verify your media with mediacheck?
Comment 2 deesto 2006-12-13 11:40:16 EST
I got this error as well on a tested and verified FC6 install CD#1.  Moreover: I
got it after doing a "workaround" to stop the installer from crashing on
selecting additional repositories after specifying a static IP address.  I left
DHCP enabled, enabled Fedora Extras, chose Customize  now, and clicked Next.

Errors in other terminals:
WARNING: Failed to get
http://download.fedora.redhat.com/pub/fedora/linux/extras/6/i386/repodata/repomd.xml
from mirror.
ERROR: exception in unmountCD: (16, 'Device or resource busy')

When I tried to umnount manually in sh-3.1:
#umount /mnt/source/
umount: Couldn't umount /mnt/source: Function not implemented
Comment 3 Anatolij D 2007-02-09 10:43:10 EST
I can confirm this also.
Burned FC6 DVD two times on two different drives, mediacheck ok, selected
components for install (default + KDE option) and at the point where it is
checking dependencies  for selected packages it fails fith "An error occured
unmounting the CD" with the all symptoms described above.
(I found that if i try to install default set of packages installation can be
completed successfully).
Comment 4 David Cantrell 2007-03-15 18:05:47 EDT
> ERROR: exception in unmountCD: (16, 'Device or resource busy')

This usually (but not always) indicates a hardware failure.  Without the
/tmp/syslog and /tmp/anaconda.log from your system, we can't diagnose the
problem completely.  Please attach those log files.
Comment 5 deesto 2007-03-15 19:36:15 EDT
> This usually (but not always) indicates a hardware failure. 

I can confirm that this was not a hardware failure: I was able to complete the
installation successfully, on the same hardware and same installation media, by
leaving the default networking (specifically, enabling DHCP) and "Extra
Repositories" (specifically, not choosing to install extras during install)
selections intact.
Comment 6 Jeremy Katz 2007-03-23 14:49:31 EDT

*** This bug has been marked as a duplicate of 212018 ***

Note You need to log in before you can comment on or make changes to this bug.