Bug 214757 - System-config-network does not save the added route
Summary: System-config-network does not save the added route
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: system-config-network   
(Show other bugs)
Version: 6
Hardware: i686
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Harald Hoyer
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2006-11-09 11:19 UTC by Need Real Name
Modified: 2007-12-12 08:36 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-12-12 08:36:59 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Fedora proble attachment (126.74 KB, image/pjpeg)
2007-12-11 16:40 UTC, tareq
no flags Details

Description Need Real Name 2006-11-09 11:19:28 UTC
From Bugzilla Helper:
User-Agent: 

Description of problem:
The program simply will not save the new route.

Version-Release number of selected component (if applicable):
system-config-network-1.3.95-1

How reproducible:
Always


Steps to Reproduce:
1.Start the system-config network
2.Edit device
3.Select Route
4.Add the new route (address, subnet mask and gateway)
5.Click OK

Actual Results:
The new route is not saved

Expected Results:
The new route should be saved

Additional info:
Component: system-config-network
Version: 1.3.95
Summary: TB94e1a8fa sharedtcpip.py:176:route_update:TypeError: sequence
item not a string or unicode object

Traceback (most recent call last):
  File "/usr/share/system-config-network/netconfpkg/gui/sharedtcpip.py",
line 284, in on_routeAddButton_clicked
    route_update(xml, device)
  File "/usr/share/system-config-network/netconfpkg/gui/sharedtcpip.py",
line 176, in route_update
    clist.append([route.Address, route.Netmask, route.Gateway])
TypeError: sequence item not a string or unicode object

Comment 1 Yu Fan 2006-11-13 13:37:45 UTC
This is caused by a minor mistake in
/usr/share/system-config-network/netconfpkg/gui/editadress.py.
To fix this, Modify line 89-91 of editadress.py to the following:
        self.route.Address = self.xml.get_widget('addressEntry').get_text()
        self.route.Netmask = self.xml.get_widget('netmaskEntry').get_text()
        self.route.Gateway = self.xml.get_widget('gatewayEntry').get_text()
Then, It'll be all right.

Comment 3 tareq 2007-12-11 16:40:07 UTC
Created attachment 284321 [details]
Fedora proble attachment

Comment 4 Harald Hoyer 2007-12-12 08:36:59 UTC
please don't attach a screenshot of a text file. attach the text file itsself.


Note You need to log in before you can comment on or make changes to this bug.