Bug 214761 - Should parse 'autodetect/*/ieee1284' foomatic entries
Should parse 'autodetect/*/ieee1284' foomatic entries
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: system-config-printer (Show other bugs)
6
All Linux
medium Severity medium
: ---
: ---
Assigned To: Tim Waugh
:
Depends On:
Blocks: FC6Update 214765
  Show dependency treegraph
 
Reported: 2006-11-09 06:46 EST by Tim Waugh
Modified: 2007-11-30 17:11 EST (History)
0 users

See Also:
Fixed In Version: 0.7.40-1.fc6
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-11-30 07:53:34 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Tim Waugh 2006-11-09 06:46:50 EST
Description of problem:
Some devices, such as the Samsung ML-2010, have only 'ieee1284' entries for
their autodetect information in foomatic.  These should be parsed for MFG and
MDL strings for matching against as well (see bug #206907 for an example of the
problems caused by not doing so).

Version-Release number of selected component (if applicable):
0.7.35-1

Fix is:
--- foomatic.py 7 Nov 2006 17:15:19 -0000       1.38
+++ foomatic.py 9 Nov 2006 11:41:00 -0000
@@ -498,2 +498,15 @@
                 self._auto_ieee1284[dict["ieee1284"]] = printer.name
+                # Also parse the ID.
+                pieces = dict["ieee1284"].split(";")
+                mfg = mdl = None
+                for piece in pieces:
+                    if piece.find (":") == -1: continue
+                    name, value = piece.split(":",1)
+                    if name == "MFG":
+                        mfg = value
+                    elif name == "MDL":
+                        mdl = value
+                if mfg and mdl:
+                    d = self._auto_make.setdefault(mfg, {})
+                    d[mdl] = printer.name
             if dict.has_key("description"):
Comment 1 Tim Waugh 2006-11-09 06:47:31 EST
Fixed in CVS.
Comment 2 Tim Waugh 2006-11-10 10:31:08 EST
Update in testing: 0.7.36-1.fc6

Note You need to log in before you can comment on or make changes to this bug.