Bug 214762 - gmond can't start because user ganglia doesn't exist
gmond can't start because user ganglia doesn't exist
Status: CLOSED NEXTRELEASE
Product: Fedora
Classification: Fedora
Component: ganglia (Show other bugs)
6
All Linux
medium Severity low
: ---
: ---
Assigned To: Jarod Wilson
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-11-09 07:03 EST by Edouard Bourguignon
Modified: 2007-11-30 17:11 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-11-09 14:11:26 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Edouard Bourguignon 2006-11-09 07:03:24 EST
Description of problem:

user ganglia is not created during ganglia-gmond installation

Version-Release number of selected component (if applicable):

ganglia-gmond-3.0.3-10.fc6

How reproducible:

static

Steps to Reproduce:
1. yum install ganglia-gmond
2. strace gmond => ganglia user doesn't exist
  
Actual results:

No useradd in the prerun section of ganglia-gmond package, but the gmond.conf
specifies to start gmond with the user ganglia. So starting ganglia failed
because ganglia user doesn't exist

Expected results:

Installing ganglia-gmond should create the user ganglia to be able to run

Additional info:

The user ganglia is indeed created with the ganglia-gmetad package, which is not
required to be installed on each node of a cluster (1 gmond per node, and only 1
gmetad to collect data, am I wrong?)
Comment 1 Jarod Wilson 2006-11-09 14:11:26 EST
Eep. Nope, you're correct, both gmetad and gmond should try to create the
ganglia user, since its not unusual to run only one or the other of the two on a
given system -- and the majority of the time, its a compute node w/only gmond.
Fixed in cvs, builds in progress right now, should hit the tree later tonight.
Also fixing for FC5 and devel.

Note You need to log in before you can comment on or make changes to this bug.