Bug 214763 - With Sun Java 1.5.0_09-b03 installed, and Desktop Effects active, no GUI Java Window displays
With Sun Java 1.5.0_09-b03 installed, and Desktop Effects active, no GUI Java...
Status: CLOSED CANTFIX
Product: Fedora
Classification: Fedora
Component: xorg-x11 (Show other bugs)
6
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: X/OpenGL Maintenance List
David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-11-09 07:07 EST by Gerard Fernandes
Modified: 2007-11-30 17:11 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-11-20 15:52:26 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Gerard Fernandes 2006-11-09 07:07:29 EST
Description of problem: Java GUI don't render with Desktop Effects active


Version-Release number of selected component (if applicable): Latest updated FC6
with Sun Java 1.5.0_09-b03


How reproducible: Always


Steps to Reproduce:
1. Install Sun Java 1.5.0_09-b03 following the recommended procedure by building
RPMs with JPackage RPM sources.
2. Install NetBeans and follow up by installing SQuireL database client
3. Make sure Desktop effects are on (check Preferences/Dektop Effects)
4. Run NetBeans
5. Run SQuireL DB client
  
Actual results:
Empty Window displays.


Expected results:
Window with the application UI componenets renedered within it.


Additional info: Sun Java v1.5.0_09-b03 installed the recommended way by
creating RPMs using JPackage source RPMs.
Comment 1 Gerard Fernandes 2006-11-09 07:08:37 EST
WORK_AROUND:
Turn off desktop effects. Java GUI applications should now render correctly -
although they donot seem to use the GTK LAF by default.
Comment 2 Adam Jackson 2006-11-20 15:52:26 EST
This is not our bug.  This is a known issue with Java's window display code,
where it waits for a ReparentNotify before drawing.  Since compiz is not a
reparenting window manager, this notification never comes.

Please file this issue with Sun.

Note You need to log in before you can comment on or make changes to this bug.