Bug 214783 - Cannot drag windows over whole screen area
Cannot drag windows over whole screen area
Status: CLOSED UPSTREAM
Product: Fedora
Classification: Fedora
Component: metacity (Show other bugs)
6
All Linux
medium Severity medium
: ---
: ---
Assigned To: Søren Sandmann Pedersen
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-11-09 09:28 EST by Duncan Innes
Modified: 2014-06-18 05:08 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-11-09 12:11:25 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Screenshot (1.29 MB, image/png)
2006-11-09 10:09 EST, Duncan Innes
no flags Details

  None (edit)
Description Duncan Innes 2006-11-09 09:28:17 EST
Description of problem: On a dual monitor setup, windows cannot be MOVED into
the very top part or very bottom part of the monitor that does NOT display the
Gnome panels. i.e. Window title bar cannot occupy the area of the second screen
that WOULD be displaying the Gnome top and bottom panels.


Version-Release number of selected component (if applicable): metacity-2.16.0-5.fc6


How reproducible: Every Time


Steps to Reproduce:
1. Fresh FC6 install
2. Install latest nvidia drivers (9629 release) from livna
3. Configure dual monitor setup with monitors side by side
4. Configure compiz (release compiz-0.0.13-0.32.20060817git.fc6) to provide all
flashy desktop effects (don't know if this is part of the issue)
5. Drag a medium sized window around the screen.
  
Actual results: Window can be dragged across the entire main monitor, but the
windows title bar cannot be dragged onto the very top and bottom of the
secondary monitor.  Seems to be that the window is avoiding being placed on top
of the Gnome panels that don't actually exist on that monitor.


Expected results: Expect to be able to drag window wherever I like.


Additional info:
Comment 1 Duncan Innes 2006-11-09 10:09:39 EST
Created attachment 140774 [details]
Screenshot

Screenshot shows dual monitor setup with single window being dragged around the
right hand monitor.

The mouse cursor is missing from the grab, but at this point I'm trying to drag
the window right to the top of the right hand monitor and the mouse pointer is
at the very top of the screen.	The window is refusing to move up past the
point at which it is shown.

The same can be done at the bottom of the screen (although slightly useless). 
The window title bar will not drag down to the very bottom of the monitor.
Comment 2 Søren Sandmann Pedersen 2006-11-09 12:11:25 EST
This bug is not something we are going to fix downstream. Please file it
upstream at 

    http://bugzilla.gnome.org/simple-bug-guide.cgi



Note You need to log in before you can comment on or make changes to this bug.