Bug 214788 - /etc/pam.d/gdm not created. gdmgreeter fails....
/etc/pam.d/gdm not created. gdmgreeter fails....
Status: CLOSED DUPLICATE of bug 196590
Product: Fedora
Classification: Fedora
Component: gdm (Show other bugs)
All Linux
medium Severity medium
: ---
: ---
Assigned To: Ray Strode [halfline]
Depends On:
  Show dependency treegraph
Reported: 2006-11-09 10:09 EST by Tom London
Modified: 2007-11-30 17:11 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2006-11-09 16:31:49 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)

  None (edit)
Description Tom London 2006-11-09 10:09:15 EST
Description of problem:
With update to gdm-2.17.2-1.fc7, /etc/pam.d/gdm is saved in
/etc/pam.d/gdm.rpmsave, but a new /etc/pam.d/gdm is not created.

This prevents gdmgreeter from doing anything interesting (like accepting
username, ....)

doing 'cp /etc/pam.d/gdm.rpmsave /etc/pam.d/gdm' seems to restore...

Version-Release number of selected component (if applicable):

How reproducible:

Steps to Reproduce:
1. update
2. reboot
Actual results:

Expected results:

Additional info:
Comment 1 Tom London 2006-11-09 10:14:38 EST
Additional info: I had 'added' lines for pam_keyring to the stock /etc/pam.d/gdm:

--- gdm.old     2006-09-29 15:32:14.000000000 -0700
+++ gdm.rpmsave 2006-09-29 15:33:27.000000000 -0700
@@ -1,5 +1,6 @@
 auth       required    pam_env.so
+auth       optional    pam_keyring.so try_first_pass keyring=WiReLeSs
 auth       include     system-auth
 account    required    pam_nologin.so
 account    include     system-auth
@@ -8,4 +9,5 @@
 session    include     system-auth
 session    required    pam_loginuid.so
 session    optional    pam_console.so
+session    optional    pam_keyring.so
Comment 2 Tom London 2006-11-09 15:07:43 EST
Appears to be rpm related problem:
Comment 3 Ray Strode [halfline] 2006-11-09 16:31:49 EST

*** This bug has been marked as a duplicate of 196590 ***

Note You need to log in before you can comment on or make changes to this bug.