Bug 214816 - Many to many scheduled diff actions
Many to many scheduled diff actions
Status: CLOSED NOTABUG
Product: Red Hat Network
Classification: Red Hat
Component: RHN/Web Site (Show other bugs)
rhn500
All Linux
medium Severity medium
: ---
: ---
Assigned To: Máirín Duffy
Beth Nackashi
:
Depends On:
Blocks: rhn500h-config-mgmt
  Show dependency treegraph
 
Reported: 2006-11-09 11:52 EST by Ken Ganong
Modified: 2007-04-18 13:52 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-02-15 15:34:02 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Ken Ganong 2006-11-09 11:52:40 EST
If a user wanted to do a diff for multiple config files to multiple servers:

There are only two places where this makes sense... when you are currently
looking at multiple servers (SSM) or when you are looking at mulitple files
(config channels pages).

In the SSM we do support choosing multiple files to multiple servers.
In the channels pages we don't.

However, on the Channel Overview page, there is a link to diff all files to all
systems. There is simply no way to do less than that.

Possible Solutions:
1. Leave things the way they are; the all to all functionality is just special.
2. Remove the all to all functionality from channel. The ssm is *the* way to do
this.
3. Add the pages to config channel for scheduling diff actions (this bug should
probably be pushed to a different release).
Comment 1 Máirín Duffy 2007-02-15 15:34:02 EST
I think #1 is fine. It gives users a one-click shortcut to verifying all the
files on the systems subscribed to the channel.

While a UI to schedule diffs from a channel is an interesting idea, I think the
primary usecase for diffing would be what we currently handle - diff all files
in the channel against all systems subscribed to the channel. If a user wanted a
finer-grained section of files against all of those systems, they could just
ignore the files they didn't care about in the diff results. If they only wanted
diff results for multiple systems for one or a small number of files, they can
easily schedule those from the files themselves.

I'm going to close this NOTABUG. If it turns out to be something customers end
up wanting to use, I think we should reopen this bug a reevaluate Ken's
suggestion #3.

Note You need to log in before you can comment on or make changes to this bug.