Bug 214819 - Satellite-sync NEEDS versioned caching!!!!!
Satellite-sync NEEDS versioned caching!!!!!
Status: CLOSED NOTABUG
Product: Red Hat Network
Classification: Red Hat
Component: RHN/Backend (Show other bugs)
rhn500
All Linux
medium Severity medium
: ---
: ---
Assigned To: Pradeep Kilambi
Brandon Perkins
: FutureFeature
Depends On:
Blocks: 471260
  Show dependency treegraph
 
Reported: 2006-11-09 11:59 EST by John Wregglesworth
Modified: 2009-03-20 16:07 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-03-20 16:07:33 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description John Wregglesworth 2006-11-09 11:59:29 EST
Description of problem: satellite-sync's caching isn't versioned. This causes an
issue where we have to manually remove the cache when the cache format changes.
What really needs to happen is that satellite-sync will detect when the version
of the cache changes and will automatically replace the cache as needed. This
will enable us to simplify the upgrade process a little bit.


Version-Release number of selected component (if applicable): All of them.


How reproducible: Always


Steps to Reproduce:
1. Upgrade rhns-server on a satellite.
2. ls -l /var/cache/rhn/
  
Actual results: /var/cache/rhn/ is wiped out.


Expected results: We should only wipe out /var/cache/rhn/ when the format of the
cache changes.


Additional info: I used capslock and multiple exclamation points just like I
said I would in IRC. :)
Comment 1 Mike McCune 2007-04-04 13:50:20 EDT
moving to 510
Comment 2 Red Hat Bugzilla 2007-04-11 21:41:08 EDT
User bnackash@redhat.com's account has been closed
Comment 5 Bill Nottingham 2009-02-27 11:23:15 EST
*** Bug 487604 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.