Bug 214826 - Poor performance under heavy i/o:
Poor performance under heavy i/o:
Status: CLOSED WONTFIX
Product: Red Hat Enterprise Linux 4
Classification: Red Hat
Component: kernel (Show other bugs)
4.0
x86_64 Linux
medium Severity high
: ---
: ---
Assigned To: Brian Maly
Brian Brock
http://www.turkeyforum.com/satforum/
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-11-09 12:21 EST by Bulent Tekcan
Modified: 2008-09-25 02:12 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-09-25 02:12:18 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Bulent Tekcan 2006-11-09 12:21:12 EST
Poor performance under heavy i/o:


2.6.9-42.0.3.ELsmp #1 SMP Mon Sep 25 17:24:31 EDT 2006 x86_64 x86_64 x86_64 
GNU/Linux

Our sites high traffic on theplanet,we have a Dual Opteron 4GB ram.Under high 
traffic this error occured.

Nov 9 17:22:23 imagine su(pam_unix)[5976]: session closed for user root 
Nov 9 17:22:46 imagine kernel: warning: many lost ticks. 
Nov 9 17:22:46 imagine kernel: Your time source seems to be instable or some 
driver is hogging interupts 
Nov 9 17:22:46 imagine kernel: rip __do_softirq+0x4d/0xd0


How reproducible:
I cannot reproduce,because only under higf traffic this error occured.After 
this problem my system unstable load goes high,and cpu %2 to 80 jumping.
Comment 2 Brian Maly 2007-02-08 16:41:07 EST
What timesource is being used here (dmesg|grep time)? Does the error go away if
a different timesource is used?



Can you try booting with each of the following boot args (one at a time) and see
if any make a difference: acpi_irq_balance, noirqbalance and idle=poll

Note You need to log in before you can comment on or make changes to this bug.